Bug 852235 - Seeing inconsistent behavior when trying to create a scalable jboss app
Seeing inconsistent behavior when trying to create a scalable jboss app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 20:06 EDT by Nam Duong
Modified: 2015-05-14 18:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:30:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-08-27 20:06:24 EDT
Description of problem:
Trying to create a scalable app with:
rhc app create -a kitchen -t jbosseap-6.0 -s

Inconsistent behaviors noticed:
- It takes a while before timing out with this message:  "MESSAGES:
Connection to server timed out. It is possible the operation finished without being able to report success. Use 'rhc domain show' or 'rhc app status' to check the status of your applications."

- In one attempt, the app doesn't get created (e.g., doesn't get listed in rhc domain show)

- In another attempt, it shows up but I can't reach it (dns entry not there?)  In this case, I have to destroy the app and try again.



Here's the debug info:
rhc app create -a kitchen -t jbosseap-6.0 -s -d
Password: ********

Submitting form:
debug: true
rhlogin: nduong+mac@redhat.com
Contacting https://openshift.redhat.com
Creating application: kitchen in macdomain
Problem reported from server. Response code was .

MESSAGES:
Connection to server timed out. It is possible the operation finished without being able to report success. Use 'rhc domain show' or 'rhc app status' to check the status of your applications.
Comment 1 Bill DeCoste 2012-08-31 18:04:12 EDT
Nam, is this just on prod? I'm unable to recreate in a devenv.
Comment 2 John Poelstra 2012-09-07 14:50:42 EDT
bill is trying to repro one more time today
Comment 3 Bill DeCoste 2012-09-07 15:11:26 EDT
Unable to reproduce in INT
Comment 4 John Poelstra 2012-09-11 13:13:01 EDT
cannot repro... sending over to QE
Comment 5 Wei Sun 2012-09-11 22:56:12 EDT
Try to do several times,but cannot reproduce this bug,so change the status to verified.

The information:
1.INT
[sunwei@dhcp-8-229 int]$ rhc app create -a kitchen -t jbosseap-6.0 -s -d
Password: ******

Submitting form:
rhlogin: wsun@redhat.com
debug: true
Contacting https://int.openshift.redhat.com
Creating application: kitchen in wsunint
DEBUG: 'kitchen' creation returned success.
Now your new domain name is being propagated worldwide (this might take a minute)...
Pulling new repo down
git clone --quiet ssh://dd5b676200374879b9e32e84de332f69@kitchen-wsunint.int.rhcloud.com/~/git/kitchen.git/ kitchen
The authenticity of host 'kitchen-wsunint.int.rhcloud.com (23.20.101.43)' can't be established.
RSA key fingerprint is cf:ee:77:cb:0e:fc:02:d7:72:7e:ae:80:c0:90:88:a7.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'kitchen-wsunint.int.rhcloud.com' (RSA) to the list of known hosts.
remote: Counting objects: 39, done.
remote: Compressing objects: 100% (30/30), done.
remote: Total 39 (delta 1), reused 0 (delta 0)
Receiving objects: 100% (39/39), 19.75 KiB, done.
Resolving deltas: 100% (1/1), done.
Checking if the application is available #1
Application kitchen is available at: http://kitchen-wsunint.int.rhcloud.com/
  Git URL: ssh://dd5b676200374879b9e32e84de332f69@kitchen-wsunint.int.rhcloud.com/~/git/kitchen.git/
To make changes to 'kitchen', commit to kitchen/.
Successfully created application: kitchen

2.devenv_2155
[sunwei@dhcp-8-229 dev]$ rhc app create -a kitchen -t jbosseap-6.0 -s -d
Password: ******

Submitting form:
rhlogin: wsun@redhat.com
debug: true
Contacting https://ec2-23-22-255-54.compute-1.amazonaws.com
Creating application: kitchen in wsunint
DEBUG: 'kitchen' creation returned success.
Now your new domain name is being propagated worldwide (this might take a minute)...
Pulling new repo down
git clone --quiet ssh://4c0d641f48654e48b5667c71abe388a8@kitchen-wsunint.dev.rhcloud.com/~/git/kitchen.git/ kitchen
remote: Counting objects: 39, done.
remote: Compressing objects: 100% (30/30), done.
remote: Total 39 (delta 1), reused 0 (delta 0)
Receiving objects: 100% (39/39), 19.75 KiB, done.
Resolving deltas: 100% (1/1), done.
Checking if the application is available #1
Application kitchen is available at: http://kitchen-wsunint.dev.rhcloud.com/
  Git URL: ssh://4c0d641f48654e48b5667c71abe388a8@kitchen-wsunint.dev.rhcloud.com/~/git/kitchen.git/
To make changes to 'kitchen', commit to kitchen/.
Successfully created application: kitchen

Note You need to log in before you can comment on or make changes to this bug.