Bug 85224 (IT_69202) - magicdev does not automount DVDs
Summary: magicdev does not automount DVDs
Status: CLOSED WONTFIX
Alias: IT_69202
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: magicdev (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-26 19:56 UTC by Mike McLean
Modified: 2013-03-13 04:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-14 18:48:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mount DVDs as well (1.19 KB, patch)
2003-02-27 12:39 UTC, Bastien Nocera
no flags Details | Diff
only launch the dvd player if we have a video dvd (2.48 KB, patch)
2003-03-29 11:14 UTC, Bastien Nocera
no flags Details | Diff
updated patch (4.45 KB, patch)
2003-05-16 14:57 UTC, Bastien Nocera
no flags Details | Diff
yet another patch (5.56 KB, patch)
2003-05-16 17:05 UTC, Bastien Nocera
no flags Details | Diff

Description Mike McLean 2003-02-26 19:56:08 UTC
* -re0225....
* magicdev-1.1.4-3

CDs are automounted, but DVDs are not.

Comment 1 Owen Taylor 2003-02-26 20:27:10 UTC
Not expected to, actually. Might be nice, but we'd have to figure
out the interaction with play-a-dvd, since you can't distinguish
a Video DVD from a data DVD.


Comment 2 Bastien Nocera 2003-02-27 12:38:49 UTC
I *think* we could also mount the DVD and still be able to access it via the DVD
program. We could then add something to Nautilus to show that it's a DVD, and
probably get the name of the film if it's a Video DVD.



Comment 3 Bastien Nocera 2003-02-27 12:39:23 UTC
Created attachment 90398 [details]
mount DVDs as well

Comment 4 Bastien Nocera 2003-03-29 10:53:59 UTC
Owen, I finally had time to test this patch, and it does what one would expect.
Can you apply the patch ?

Comment 5 Bastien Nocera 2003-03-29 11:14:21 UTC
Created attachment 90783 [details]
only launch the dvd player if we have a video dvd

2003-03-29  Bastien Nocera  <hadess@hadess.net>
									       

	* daemon.c: (is_video_dvd), (app_device_activate_cdrom),
	(app_device_mount): mount DVDs all the time, but only launch the
	DVD player if it's a video DVD, mount the media synchronously so we
	know that it will be mounted when we return, check if mount was
	successful before saying it is mounted

Comment 6 Bastien Nocera 2003-05-16 14:57:35 UTC
Created attachment 91724 [details]
updated patch

Hmm, I don't remember what you told me was wrong with the previous patch,
Owen...
But I updated it not to change dev->did_mount, and check if the dvd was mounted
before running the DVD player program.

Comment 7 Owen Taylor 2003-05-16 15:53:15 UTC
I seem to remember that what we discussed was that if we mount DVD's,
then playing DVDs should be handled in the same location as 
autorun, not in the same place we handle playing CD's.


Comment 8 Bastien Nocera 2003-05-16 17:05:31 UTC
Created attachment 91734 [details]
yet another patch

Comment 9 Bastien Nocera 2003-12-15 00:13:25 UTC
Merged upstream

2003-12-15  Bastien Nocera  <hadess@hadess.net>
                                                                     
          
        * .cvsignore: upd
        * daemon.c: (is_video_dvd), (app_device_activate_cdrom),
        (app_device_mount), (run_me), (app_device_autorun):
        make magicdev automount data DVDs, and double-check if a DVD is
        a video one before launching the application


Comment 10 John (J5) Palmieri 2004-08-25 17:43:46 UTC
Closing.

Comment 11 John (J5) Palmieri 2005-04-05 15:28:46 UTC
New packages going through the errata process for RHEL3-QU6 release. 

Comment 12 John (J5) Palmieri 2005-10-14 18:48:34 UTC
This package did not fit the update guidelines (specificly the one about not
adding new functionality) so it was dropped from the QU6 release and is now
being closed WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.