Bug 852245 - the disable option should remain disable after apply the config in kdump page
the disable option should remain disable after apply the config in kdump page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 22:13 EDT by Mohua Li
Modified: 2016-04-26 11:37 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Previously in Red Hat Enterprise Virtualization Hypervisor's kdump TUI, SSH and NFS locations remained possible options for vmcore files generated by kdump when local storage had been selected. Now, if local storage for vmcore files is selected, NFS and SSH paths are not allowed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:38:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohua Li 2012-08-27 22:13:05 EDT
Description of problem:
in kdump TUI page, choose save the vmcore file to local storage, and apply the change, the previous disable option nfs & ssh location, will become enable, cursor go through these 2 option, will get annoying message, but if choose nfs, it will disable ssh location setting, after apply, it will remain disable, 


Version-Release number of selected component (if applicable):
rhev-hypervisor 6.3-20120815

How reproducible:
always

Steps to Reproduce:
1.in kdump TUI page, choose local
2.and try to apply the config, 
3.
  
Actual results:
after apply succeed, nfs & ssh location will become enable

Expected results:
after apply succeed, nfs & ssh location should remain disable,


Additional info:
Comment 2 Fabian Deutsch 2012-09-19 08:47:05 EDT
This is only reproducable with an enabled netwok.
Comment 3 Fabian Deutsch 2012-09-19 08:55:14 EDT
The patch bewlo changes the behavior.
The entries will be disabled if:
a) the network is down
or
b) neither ssh nor nfs storage is choosen

http://gerrit.ovirt.org/#/c/8056/
Comment 5 Fabian Deutsch 2012-09-27 09:27:39 EDT
Tested as follows:

1. Installed recent rhevh
2. Applied patch
3. Login to menu and neter kdump page
4. select local
5. hit <apply>
= ssh+nfs locations are disabled
Comment 7 cshao 2012-10-31 03:28:09 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6.
ovirt-node-2.5.0-7.el6_4.noarch

Test steps:
1. ENter kdump page, select local.
2. hit <apply>
= ssh+nfs locations are disabled
So the bug is fixed, change bug status to VERIFIED.
Comment 8 cshao 2012-12-27 20:29:01 EST
Re-test with version rhev-hypervisor6-6.4-20121212.1.el6,

Test steps:
1. ENter kdump page, select local.
2. hit <apply>
= ssh+nfs locations are disabled
So the bug was fixed.
Comment 10 errata-xmlrpc 2013-02-28 11:38:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.