Bug 852256 - kitchensink-example quickstart fails on jbosseap-6.0
kitchensink-example quickstart fails on jbosseap-6.0
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 23:16 EDT by Nam Duong
Modified: 2015-05-14 18:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-08-27 23:16:42 EDT
Description of problem:
I followed https://github.com/openshift/kitchensink-example with jbosseap-6.0 and it failed to start with the error: 

JBAS014775:    New missing/unsatisfied dependencies:
      service jboss.ejb3.connector (missing) dependents: [service jboss.ejb3.localEjbReceiver.value, service jboss.ejb3.localEjbReceiver.reference]
      service jboss.remoting.endpoint.subsystem (missing) dependents: [service jboss.naming.remote, service jboss.ejb3.localEjbReceiver.value, service jboss.ejb3.localEjbReceiver.reference]

2012/08/27 20:07:59,987 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1) started (with errors) in 38406ms- Started 168 of 221 services (15 services failed or missing dependencies, 35 services are passive or on-demand)


Steps:
rhc app create -a kitchensink -t jbosseap-6.0
cd kitchensink
git remote add upstream -m master git://github.com/openshift/kitchensink-example.git
git pull -s recursive -X theirs upstream master
git push

Then reviewed the log when the app didn't work.
Comment 1 Nam Duong 2012-08-27 23:17:55 EDT
BTW:  Tried jbossas-7 (scalable and non-scalable) and it worked just fine.
Comment 2 John Poelstra 2012-09-07 14:33:56 EDT
verifying if this is a quickstart problem or not
Comment 3 Bill DeCoste 2012-09-07 15:07:35 EDT
Just saw Nam's last comment, so this is a problem with the quickstart being specific to AS7 and not EAP6. Need to doc the quickstart or create a new one for EAP6
Comment 4 Bill DeCoste 2012-09-07 18:17:51 EDT
Looks like this is a problem with the EAP6 configuration in OpenShift.
Comment 5 Bill DeCoste 2012-09-07 19:00:48 EDT
Removed the AS7 specific standalone.xml from the quickstart. App now deploys to EAP6.
Comment 6 Jianwei Hou 2012-09-10 04:56:09 EDT
Verified on devenv_2140

Steps:
1. Create a jbosseap-6.0 application, follow the steps in https://github.com/openshift/kitchensink-example

rhc app create -a kitchensink -t jbosseap-6.0
cd kitchensink
git remote add upstream -m master git://github.com/openshift/kitchensink-example.git
git pull -s recursive -X theirs upstream master
git push
2. Access application, app is running well
3. Repeat step 1 ~ step 2 for a jbossas-7 application, no error occur

Note You need to log in before you can comment on or make changes to this bug.