This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 852387 - libvirtd gets SIGABRT during startup (BUG: route/tc.c:970)
libvirtd gets SIGABRT during startup (BUG: route/tc.c:970)
Status: CLOSED DUPLICATE of bug 852549
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 06:55 EDT by Adam Tkac
Modified: 2013-04-30 19:52 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 19:06:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2012-08-28 06:55:36 EDT
Description of problem:
libvirtd gets SIGABRT during startup. This is complete error log:

[root@evileye tigervnc]# /usr/sbin/libvirtd  -vvv
BUG: route/tc.c:970
libvirtd: route/tc.c:970: rtnl_tc_register: Assertion `0' failed.
Caught abort signal dumping internal log buffer:


    ====== start of log =====

2012-08-28 10:44:09.379+000022865: debug : main:1120 : Decided on pid file path '/var/run/libvirtd.pid'
2012-08-28 10:44:09.379+000022865: debug : main:1130 : Decided on socket paths '/var/run/libvirt/libvirt-sock' and '/var/run/libvirt/libvirt-sock-ro'
2012-08-28 10:44:09.379+000022865: debug : main:1168 : Ensuring run dir '/var/run/libvirt' exists
2012-08-28 10:44:09.379+000022865: debug : virNetlinkStartup:129 : Running global netlink initialization
2012-08-28 10:44:09.379+000022865: debug : virEventRegisterDefaultImpl:204 : registering default event implementation
2012-08-28 10:44:09.379+000022865: debug : virEventPollAddHandle:111 : Used 0 handle slots, adding at least 10 more
2012-08-28 10:44:09.379+000022865: debug : virEventPollInterruptLocked:697 : Skip interrupt, 0 0
2012-08-28 10:44:09.379+000022865: debug : virEventPollAddHandle:136 : EVENT_POLL_ADD_HANDLE: watch=1 fd=5 events=1 cb=0x7fadb35a3010 opaque=(nil) ff=(nil)
2012-08-28 10:44:09.379+000022865: debug : virEventRegisterImpl:177 : addHandle=0x7fadb35a3b20 updateHandle=0x7fadb35a3a10 removeHandle=0x7fadb35a3430 addTimeout=0x7fadb35a3590 updateTimeout=0x7fadb35a3760 removeTimeout=0x7fadb35a3890
2012-08-28 10:44:09.379+000022865: debug : virNetServerNew:407 : srv=0x88b530 refs=1
2012-08-28 10:44:09.379+000022865: debug : main:1206 : Dropping privileges (if required)
2012-08-28 10:44:09.379+000022865: debug : virDriverModuleInitialize:53 : Module dir /usr/lib64/libvirt/connection-driver
2012-08-28 10:44:09.379+000022865: debug : virDriverLoadModule:66 : Module load network
2012-08-28 10:44:09.379+000022865: debug : virRegisterNetworkDriver:564 : registering Network as network driver 5
2012-08-28 10:44:09.379+000022865: debug : virDriverLoadModule:66 : Module load storage
2012-08-28 10:44:09.432+000022865: debug : virRegisterStorageDriver:624 : registering storage as storage driver 6
2012-08-28 10:44:09.432+000022865: debug : virDriverLoadModule:66 : Module load nodedev
2012-08-28 10:44:09.433+000022865: debug : udevNodeRegister:1779 : Registering udev node device backend
2012-08-28 10:44:09.433+000022865: debug : virRegisterDeviceMonitor:654 : registering udevDeviceMonitor as device driver 4
2012-08-28 10:44:09.433+000022865: debug : virDriverLoadModule:66 : Module load secret
2012-08-28 10:44:09.433+000022865: debug : virRegisterSecretDriver:684 : registering secret as secret driver 4
2012-08-28 10:44:09.433+000022865: debug : virDriverLoadModule:66 : Module load nwfilter
2012-08-28 10:44:09.434+000022865: debug : virRegisterNWFilterDriver:714 : registering nwfilter as network filter driver 4
2012-08-28 10:44:09.434+000022865: debug : virDriverLoadModule:66 : Module load interface

     ====== end of log =====

Aborted

Version-Release number of selected component (if applicable):
$ rpm -q libvirt-daemon libnl3 netcf-libs
libvirt-daemon-0.10.0-0rc0.2.fc18.x86_64
libnl3-3.2.7-1.fc18.x86_64
netcf-libs-0.2.2-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. service libvirtd start
  
Actual results:
libvirtd daemon crashes

Expected results:
running libvirtd

Additional info:
It seems archlinux had same issue:
https://bbs.archlinux.org/viewtopic.php?id=141684

However if I read correctly, they solved this issue by downgrade of libvirt and netcf.
Comment 1 Daniel Berrange 2012-08-28 19:04:01 EDT
This is the libnl.so compatibility issue. The new netcf uses libnl.so.3 while libvirt uses libnl.so.1. We need a new libvirt build to use libnl.so.3
Comment 2 Eric Blake 2012-08-28 19:06:41 EDT

*** This bug has been marked as a duplicate of bug 852549 ***

Note You need to log in before you can comment on or make changes to this bug.