Bug 852468 - device-mapper* subpackages versioning could cause troubles
device-mapper* subpackages versioning could cause troubles
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 10:54 EDT by Jan Blazek
Modified: 2012-08-28 13:16 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 13:16:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Blazek 2012-08-28 10:54:24 EDT
device-mapper* subpackages of lvm2 package have different version than main lvm2 package. device-mapper NVR is glued together from %{device_mapper_version} and lvm2's %{release}. There could possibly occur a dangerous situation when lvm2 version increases, %{device_mapper_version} wouldn't change but because of lower %release the resulting device-mapper's NVR would be lower than what was already shipped to customers.
Comment 2 Alasdair Kergon 2012-08-28 13:16:19 EDT
"There could possibly occur a dangerous situation when lvm2 version increases, %{device_mapper_version} wouldn't change but because of lower %release "

The %release is NOT lower in such circumstances: your scenario does not arise.
Releases that only affect lvm2, not dm, are rare anyway and unlikely ever to arise in RHEL.  (Version numbers are controlled by upstream and both always change in a .y RHEL release, and neither changes in a .z release.)

Note You need to log in before you can comment on or make changes to this bug.