Bug 852469 - bash - Inconsistency between man page and help
bash - Inconsistency between man page and help
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
18
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 10:56 EDT by Filip Holec
Modified: 2016-04-18 06:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 08:14:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Holec 2012-08-28 10:56:53 EDT
Description of problem:
In bash help message, options --protected and --debug are mentioned (and valid), but they are the only options not on man page. Moreover, option -l is on man page, but not mentioned in help (shell options part).

Version-Release number of selected component (if applicable):
bash-4.2.37-3.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Check man page
2. Check --help option
  
Actual results:
Inconsistent man page/help

Expected results:
Consistent man page/help

Additional info:
Comment 1 Roman Rakus 2012-09-14 08:10:36 EDT
(In reply to comment #0)
Thanks for the report.
> Description of problem:
> In bash help message, options --protected and --debug are mentioned (and
> valid), but they are the only options not on man page. Moreover, option -l
> is on man page, but not mentioned in help (shell options part).
Long options are just printed out in regards of which all options are possible, in other words, the text is generated. Probably it makes sense to add options to man page and info doc. 
Short options are stored as a string, I will add missing option.
Comment 2 Roman Rakus 2012-09-14 08:27:00 EDT
--debug has no effect, it is there probably for some compatibility. Asked upstream.
--protected will force that there will not be performed process nor command substitutions.

adding -l short option will be easy to fix.
Comment 3 Roman Rakus 2012-09-14 08:37:40 EDT
-l is already fixed in git repository and will be fixed in next release.
Comment 4 Roman Rakus 2012-09-14 09:22:23 EDT
--protected is not usable, since it depends on compile time option WORDEXP_OPTION and this option is not turned on in Fedora nor RHEL. I have posted a patch upstream.
Comment 5 Roman Rakus 2012-10-15 08:14:00 EDT
Upstream already fixed it and it will occur in next release of bash.

Note You need to log in before you can comment on or make changes to this bug.