Bug 852501 - Fix FTBFS on f18 and rawhide
Fix FTBFS on f18 and rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-vrapper (Show other bugs)
18
All Linux
high Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 13:54 EDT by Roland Grunberg
Modified: 2013-01-10 01:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:57:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to 0.22.0 (2.14 KB, patch)
2012-08-28 13:56 EDT, Roland Grunberg
no flags Details | Diff

  None (edit)
Description Roland Grunberg 2012-08-28 13:54:08 EDT
I've noticed that eclipse-vrapper is ftbfs on f18, and likely rawhide as well. I can't see the build logs, but I believe this is because %{_libdir} will no longer resolve properly for noarch packages. Luckily this is used only for the pdebuild script, which is now in %{_bindir} and so it can be called directly.

In addition, with Eclipse 4.2.0, version 0.18.0 is failing due to the usage of internal classes that are no longer present. (See https://github.com/vrapper/vrapper/commit/112125b96d3329dddb2cd3aa2b4f82f26eef0b64). This is fixed in version 0.22.0 upstream so an update would be ideal.

Scratch build : http://koji.fedoraproject.org/koji/taskinfo?taskID=4431629
Comment 1 Roland Grunberg 2012-08-28 13:56:21 EDT
Created attachment 607671 [details]
Update to 0.22.0
Comment 2 Jesse Keating 2012-08-28 14:58:31 EDT
Thanks!  I'll check upstream to see if there is a new release.
Comment 3 Fedora Update System 2012-08-29 12:11:18 EDT
eclipse-vrapper-0.22.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eclipse-vrapper-0.22.0-1.fc18
Comment 4 Fedora Update System 2012-08-29 14:45:34 EDT
Package eclipse-vrapper-0.22.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-vrapper-0.22.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12947/eclipse-vrapper-0.22.0-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-12-20 10:57:52 EST
eclipse-vrapper-0.22.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.