Bug 852540 - WARNING: at drivers/net/wireless/iwlwifi/iwl-agn-tx.c:1179 iwlagn_rx_reply_tx+0x941/0x970
WARNING: at drivers/net/wireless/iwlwifi/iwl-agn-tx.c:1179 iwlagn_rx_reply_tx...
Status: CLOSED DUPLICATE of bug 862111
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 16:44 EDT by Dhaval Giani
Modified: 2012-10-05 09:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 09:00:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dhaval Giani 2012-08-28 16:44:10 EDT
Description of problem:
My dmesg is filled up with

[ 3199.501702] ------------[ cut here ]------------
[ 3199.501707] WARNING: at drivers/net/wireless/iwlwifi/iwl-agn-tx.c:1179 iwlagn_rx_reply_tx+0x941/0x970 [iwlwifi]()
[ 3199.501708] Hardware name: 4286CT0
[ 3199.501709] Modules linked in: fuse bnep bluetooth ip6table_filter ip6_tables ebtable_nat ebtables be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i tpm_bios cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack xt_CHECKSUM iptable_mangle bridge stp llc xts gf128mul dm_crypt uvcvideo snd_hda_codec_hdmi videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media snd_hda_codec_conexant arc4 iwlwifi mac80211 cfg80211 thinkpad_acpi snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_timer snd soundcore rfkill e1000e lpc_ich mei mfd_core coretemp i2c_i801 microcode vhost_net nfsd nfs_acl auth_rpcgss lockd sunrpc tun macvtap macvlan kvm_intel kvm binfmt_misc uinput crc32c_intel ghash_clmulni_intel sdhci_pci sdhci mmc_core wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
[ 3199.501744] Pid: 0, comm: swapper/0 Tainted: G        W    3.5.2-3.fc17.x86_64 #1
[ 3199.501744] Call Trace:
[ 3199.501745]  <IRQ>  [<ffffffff810584bf>] warn_slowpath_common+0x7f/0xc0
[ 3199.501750]  [<ffffffff8105851a>] warn_slowpath_null+0x1a/0x20
[ 3199.501755]  [<ffffffffa04986d1>] iwlagn_rx_reply_tx+0x941/0x970 [iwlwifi]
[ 3199.501757]  [<ffffffff8101a953>] ? native_sched_clock+0x13/0x80
[ 3199.501763]  [<ffffffffa04a3007>] iwl_rx_dispatch+0xb7/0x120 [iwlwifi]
[ 3199.501769]  [<ffffffffa04b0d10>] iwl_irq_tasklet+0x790/0xb00 [iwlwifi]
[ 3199.501772]  [<ffffffff81061403>] tasklet_action+0x63/0xd0
[ 3199.501777]  [<ffffffff81060e90>] __do_softirq+0xc0/0x1e0
[ 3199.501782]  [<ffffffff8101a953>] ? native_sched_clock+0x13/0x80
[ 3199.501788]  [<ffffffff81615d5c>] call_softirq+0x1c/0x30
[ 3199.501793]  [<ffffffff81015225>] do_softirq+0x75/0xb0
[ 3199.501808]  [<ffffffff81061265>] irq_exit+0xb5/0xc0
[ 3199.501810]  [<ffffffff816165b3>] do_IRQ+0x63/0xe0
[ 3199.501812]  [<ffffffff8160cc2a>] common_interrupt+0x6a/0x6a
[ 3199.501813]  <EOI>  [<ffffffff810a71a4>] ? ktime_get+0x64/0xe0
[ 3199.501817]  [<ffffffff8132b4aa>] ? intel_idle+0xea/0x150
[ 3199.501819]  [<ffffffff8132b48b>] ? intel_idle+0xcb/0x150
[ 3199.501822]  [<ffffffff814ba8c9>] cpuidle_enter+0x19/0x20
[ 3199.501824]  [<ffffffff814baee9>] cpuidle_idle_call+0xa9/0x240
[ 3199.501826]  [<ffffffff8101c55f>] cpu_idle+0xaf/0x120
[ 3199.501829]  [<ffffffff815e97de>] rest_init+0x72/0x74
[ 3199.501833]  [<ffffffff81cf6c2a>] start_kernel+0x3b7/0x3c4
[ 3199.501836]  [<ffffffff81cf6672>] ? repair_env_string+0x5e/0x5e
[ 3199.501840]  [<ffffffff81cf6356>] x86_64_start_reservations+0x131/0x135
[ 3199.501843]  [<ffffffff81cf645a>] x86_64_start_kernel+0x100/0x10f
[ 3199.501845] ---[ end trace 58ac911d0140fe96 ]---


Version-Release number of selected component (if applicable):
3.5.2-3.fc17.x86_64

How reproducible:
Sporadic

Steps to Reproduce:
1. Try to connect to the wifi at linuxcon/LPC
2.
3.
  
Actual results:
Doesn't connect, and has the warning pasted above

Expected results:
connect to the wifi

Additional info:
i am at LPC/Linuxcon and I seem to have all the luck connecting to the wifi. If you want to, we can sit for a while and see if this hits again.
Comment 1 Dave Jones 2012-09-06 14:07:00 EDT
This is the f17 dupe of f16 bug 810657, so this looks like it's been around since at least 3.3
Comment 2 Stanislaw Gruszka 2012-10-05 09:00:56 EDT

*** This bug has been marked as a duplicate of bug 862111 ***

Note You need to log in before you can comment on or make changes to this bug.