Bug 852549 - libvirt crashes then refuses to start again in F18
libvirt crashes then refuses to start again in F18
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 852387 852717 856524 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 17:58 EDT by Adam Williamson
Modified: 2012-09-18 21:20 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 21:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from gdb (24.03 KB, text/plain)
2012-08-28 17:58 EDT, Adam Williamson
no flags Details
File: backtrace (34.89 KB, text/plain)
2012-09-18 17:36 EDT, Patrick Talbert
no flags Details

  None (edit)
Description Adam Williamson 2012-08-28 17:58:01 EDT
Not entirely sure of the reproducer for this, but after my F18 system had been up for some time and I'd been using VMs periodically, I switched to virt-manager and found it not connected to libvirt. systemctl showed libvirt as having crashed. Trying to start it again either directly or via systemctl causes an immediate core dump. Attached is the trace from just running /usr/sbin/libvirtd through gdb.
Comment 1 Adam Williamson 2012-08-28 17:58:24 EDT
Created attachment 607701 [details]
backtrace from gdb
Comment 2 Eric Blake 2012-08-28 18:02:46 EDT
This is a known issue - we are waiting for a build of libvirt against netcf-0.2.2 in order to consistently use libnl-3 across the library (the crash you are seeing is a combination of libnl-1 from libvirt and libnl-3 from netcf).  In the meantime, downgrade netcf (that is, the netcf from updates-testing is unusable unless you also pair it with the to-be-built libvirt 0.10.0).
Comment 3 Eric Blake 2012-08-28 18:03:35 EDT
Discussed in this thread:
https://www.redhat.com/archives/libvir-list/2012-August/msg01704.html
Comment 4 Eric Blake 2012-08-28 19:06:41 EDT
*** Bug 852387 has been marked as a duplicate of this bug. ***
Comment 5 Eric Blake 2012-08-29 11:02:58 EDT
*** Bug 852717 has been marked as a duplicate of this bug. ***
Comment 6 Adam Tkac 2012-09-06 10:56:41 EDT
I just downloaded libvirt-0.10.1-2.fc18 from koji and it works fine for me.
Comment 7 Laine Stump 2012-09-06 16:55:21 EDT
Actually, it could be caused either by having new libvirt + old netcf, or by having old libvirt + new netcf. (in this context, "new" means "built with libnl3-devel" and "old" means "built with libnl-devel (aka 1.1)").

As far as I can see the f18 repos are stuck at libvirt-0.10.0rc0, which is an "old" build, f18 stable is at netcf-0.2.1 ("old") and f18 updates-testing is at netcf-0.2.2 ("new"). (The libvirt-0.10.1-2 build Adam is talking about is only in koji, not in any repo yet.).

My guess is that anyone just updating with yum and *not* including updates-testing will have no problems, but someone updating with yum including updates-testing will crash due to netcf being "too new". On the other hand, someone who builds/installs libvirt manually and takes netcf from the repo *without* updates-testing will crash due to libvirt being too new.

There is currently a freeze in place, so nothing new can move to stable, however I think we can still put a new libvirt into updates-testing, which should solve the problem for everyone except those who don't have updates-testing, yet want to build libvirt locally.

Said update should include the specfile change I mention in Bug 853381 (which I think is a separate bug - that bug seems to be about having an old netcf, while this bug seems to be about having an old libvirt).
Comment 8 Laine Stump 2012-09-12 07:09:26 EDT
*** Bug 856524 has been marked as a duplicate of this bug. ***
Comment 9 Laine Stump 2012-09-12 11:09:05 EDT
An update has been submitted, and will be in the updates-testing repo "soon" (usually completed within a day I think):

  https://admin.fedoraproject.org/updates/libvirt-0.10.1-2.fc18

updating with that will solve the problem (although it doesn't include the patch in Bug 853381 to force a netcf update, the people at this bug are those who've already updated netcf anyway).
Comment 10 Patrick Talbert 2012-09-18 17:36:51 EDT
Installed virtualization with 'yum --disablerepo=updates-testing install @virtualization'

enable/start libvirtd.service and this is the result.


backtrace_rating: 4
Package: libvirt-daemon-0.10.0-0rc0.2.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 11 Patrick Talbert 2012-09-18 17:36:55 EDT
Created attachment 614137 [details]
File: backtrace
Comment 12 Laine Stump 2012-09-18 21:20:45 EDT
libvirt-0.10.1-4.fc18 has been pushed to the Fedora 18 stable repository. It solves the problem described here by linking against libnl-3 rather than libnl-1.

Note You need to log in before you can comment on or make changes to this bug.