Bug 852703 - DOC: Install Proxy Server Components, wrong Prerequisites
DOC: Install Proxy Server Components, wrong Prerequisites
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-HTTP-Connectors-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 07:02 EDT by Michal Karm Babacek
Modified: 2012-11-08 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:11:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Karm Babacek 2012-08-29 07:02:49 EDT
Quote:
5.2. Install Proxy Server Components
    Prerequisites
    JBoss Enterprise Web Server v1.0.1 or later installed.
    JBoss Enterprise Application Platform 5 Native components downloaded.
end quote.

No. We ship EWS2 with mod_cluster in Tomcats and Httpd. No EWS1, no EAP5.
Comment 1 Misha H. Ali 2012-08-29 22:14:16 EDT
The prerequisites are now removed. This bug will be set to ON_QA once the change appears on the stage.
Comment 3 Radim Hatlapatka 2012-10-12 03:46:15 EDT
The steps in 5.2. are not updated and are still as there is still necessary to download and unzip mod_cluster natives from EAP distribution, which is wrong, because they are already shipped with EWS.

Also in in 6.2. Configure a Load-balancing Proxy Using the HTTP Connector sentence about installing modules:

"Install JBoss HTTP Connector modules. Refer to Chapter 5, Proxy Server Components for details"

Also it irrelevant because mod_cluster modules are already installed in EWS 2.0 httpd and tomcats
Comment 4 Radim Hatlapatka 2012-10-12 05:23:30 EDT
Actually the whole Section 5.2 is unneeded as mod_cluster is already configured correctly in EWS httpd, thereby there should be just some note regarding it is already preconfigured and next section already points how to update the configuration.
Comment 5 Misha H. Ali 2012-10-12 23:20:39 EDT
* Removed line about referring to EAP Install Guide to find mod_cluster natives. (ignore, third point removed need for this)

* Updated 6.2 to state that the only prerequisite for the procedure is an installation of EWS 2.0.

* Removed contents of 5.2, replaced with note as in comment#4.
Comment 6 Misha H. Ali 2012-10-13 02:01:10 EDT
(In reply to comment #5)
> * Removed line about referring to EAP Install Guide to find mod_cluster
> natives. (ignore, third point removed need for this)
> 
> * Updated 6.2 to state that the only prerequisite for the procedure is an
> installation of EWS 2.0.
> 

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/HTTP_Connectors_Load_Balancing_Guide/ch06s02.html

> * Removed contents of 5.2, replaced with note as in comment#4.

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/HTTP_Connectors_Load_Balancing_Guide/sect-mod_cluster-proxy-Install_Config.html
Comment 7 Radim Hatlapatka 2012-10-15 07:44:40 EDT
Section 5.2:
There is no JBoss Enterprise Data Grid 2.0, it should be JBoss Enterprise Web Server 2.0

Section 6.2: ok
Comment 8 Misha H. Ali 2012-10-15 19:56:00 EDT
Fixed reference to Data Grid, should no longer appear once new version is up.

This bug will be set to ON_QA once the changes appear on the stage.
Comment 10 Misha H. Ali 2012-11-08 17:11:06 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.