Bug 852705 - DOC: 7.2.1. Configure a JBoss Enterprise Application Server 6
DOC: 7.2.1. Configure a JBoss Enterprise Application Server 6
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-HTTP-Connectors-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 07:04 EDT by Michal Karm Babacek
Modified: 2012-11-08 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:11:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Karm Babacek 2012-08-29 07:04:34 EDT
Quote:
7.2.1. Configure a JBoss Enterprise Application Server 6 Worker Node
end quote.

We work with Tomcats and Httpd in the scope of EWS2.
Comment 1 Misha H. Ali 2012-08-29 21:28:45 EDT
So the EAP6 configuration should be removed entirely? Copying Jean-Frederic as SME to confirm this.
Comment 2 Jean-frederic Clere 2012-08-30 04:41:07 EDT
Np it must be there as the EWS can be used as a frond-end to EAP6.
Comment 3 Misha H. Ali 2012-09-18 21:50:19 EDT
Just to clarify, Jean-Frederic, does this mean that we need to add content for Tomcat and Httpd as well, or can we just leave it at EAP6 only?
Comment 4 Jean-frederic Clere 2012-09-19 08:05:49 EDT
We need to add the configuration for Tomcats.
Comment 5 Misha H. Ali 2012-09-20 19:44:24 EDT
Jean-Frederic, could you point me to a working configuration for Tomcat Worker Node?
Comment 6 Jean-frederic Clere 2012-09-21 02:29:14 EDT
Hm your 7.2.2. Configure a Tomcat Worker Node in the doc looks ok now so I don't see what you need.

But the chap8 is still not ok: JBOSS_EAP_DIST/jboss-as/server/PROFILE/mod-cluster.sar/META-INF/mod-cluster-jboss-beans.xml is wrong. in EAP6 there is only one file to configure the whole thing standalone/configuration/standalone-ha.xml. Note that the <mod-cluster-config/> are all OK except the first one:
<mod-cluster-config advertise='false" connector="ajp">
because it needs a proxy-list=something which you describe later in the doc.
Comment 7 Jean-frederic Clere 2012-09-21 02:30:06 EDT
chap8 in fact it is in 8.1.
Comment 8 Misha H. Ali 2012-09-23 19:04:02 EDT
Thanks, Jean-Frederic. Closing this bug now that 7.2.1 is OK and the issue in section 8.1. is tracked at the following:

https://bugzilla.redhat.com/show_bug.cgi?id=852709
Comment 9 Radim Hatlapatka 2012-10-22 08:42:53 EDT
It seems ok
Comment 10 Misha H. Ali 2012-11-08 17:11:07 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.