Bug 852794 - RFE: Tools to streamline backup and restore process of RHEV-M.
RFE: Tools to streamline backup and restore process of RHEV-M.
Status: CLOSED DUPLICATE of bug 960280
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miki Kenneth
yeylon@redhat.com
http://www.ovirt.org/Backup_And_Resto...
integration
: FutureFeature
: 856769 (view as bug list)
Depends On:
Blocks: 856769
  Show dependency treegraph
 
Reported: 2012-08-29 11:42 EDT by Stephen Gordon
Modified: 2016-04-18 02:44 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-07 14:07:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgrinber: Triaged+


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-08-29 11:42:23 EDT
Description of problem:

The documentation team are currently tasked with writing and maintaining backup/restore procedures. These procedures are intended for use when:

- Moving the Manager to a new machine.
- Restoring the Manager following catastrophic failure.

The backup and restore procedures are very manual and leave lots of room for user error. It would be ideal to have tooling support to streamline this process. In particular I would like to see:

A rhevm-backup utility that automatically backs up the database, RHEV-M configuration files, certificates, etc. into an archive.

A rhevm-restore utility that automatically restores these from the archive specified. Ideally it would also (optionally) be able to run rhevm-setup first with the same values as were used for the original setup.
Comment 1 Raul Cheleguini 2012-09-04 15:09:03 EDT
Hi,

I'm not sure whether this also applies to same request, but I think will be interesting rhevm-setup also offering a backup cron job configuration during the installation time, as it already does with firewall configuration.

Thank you,
rcheleguini.
Comment 2 Stephen Gordon 2012-09-14 16:21:40 EDT
Bug # 852874 and Bug # 852876 imply that we now have backup and restore db scripts, but it should be noted that this does not fully implement what I requested. In particular backup/restore of configuration files.
Comment 5 Alex Lourie 2013-02-19 07:25:04 EST
Opened a whiteboard community page for the feature: http://www.ovirt.org/Backup_And_Restore_Engine
Comment 6 Simon Grinberg 2013-03-19 09:25:08 EDT
*** Bug 856769 has been marked as a duplicate of this bug. ***
Comment 7 Itamar Heim 2013-11-30 14:31:44 EST
steve - duplicate of bug 960280?
Comment 8 Itamar Heim 2013-12-07 14:07:02 EST

*** This bug has been marked as a duplicate of bug 960280 ***

Note You need to log in before you can comment on or make changes to this bug.