Bug 85283 - Upgrade stopped due to misconfiguration of /etc/fstab
Upgrade stopped due to misconfiguration of /etc/fstab
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-27 09:00 EST by Roman Szarowski
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-27 17:48:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Szarowski 2003-02-27 09:00:19 EST
Description of problem:

When I was trying to upgrade my redhat from 8.0.93 to 8.0.94, installation process
did not let me upgrade due to changes in a partition not related to linux (vfat).
Installator has just looked probably to /etc/fstab and allow only "Cancel" or
"Reboot".
When I changed fstab, installation proceeded.

Version-Release number of selected component (if applicable):

8.0.93

How reproducible:


Steps to Reproduce:
1. Boot installation
2. Upgrade
3. Choose packages and install
    
Actual results: Installation stopped due to misconfiguration in fstab


Expected results: To check root partition and to allow installation no matter if
there are
changes in other partitions.


Additional info:
Comment 1 Jeremy Katz 2003-02-27 12:21:12 EST
Determining what's an "essential" filesystem to be mounted vs not is virtually
impossible considering you could have symlinks wherever you want on one
filesystem pointing to another, so we require that all filesytems in the fstab
be mounted for an upgrade to continue.
Comment 2 Roman Szarowski 2003-02-27 17:20:50 EST
And what about to ask the user in a separate dialog whether he is going 
to change fstab ? It would be exactly the same what I had to do. 
I changed the fstab and launched the installation again (just wasting 
of time). 
Comment 3 Jeremy Katz 2003-02-27 17:48:47 EST
anaconda assumes that you have a well-formed system on an upgrade.  Having your
fstab be correct is one part of this.

Note You need to log in before you can comment on or make changes to this bug.