Bug 852866 - aeolus-upgrade hits "aeolus-services: unrecognized service"
aeolus-upgrade hits "aeolus-services: unrecognized service"
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Steve Linabery
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 15:48 EDT by Dave Johnson
Modified: 2012-12-04 10:18 EST (History)
4 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.14-1.el6cf
Doc Type: Bug Fix
Doc Text:
aeolus-upgrade attempted 'service aeolus-services stop' to stop services. This resulted in an error because aeolus-services was not a system service. This patch changes the stop method in aeolus-upgrade to call aeolus-services directly. aeolus-upgrade now stops all services successfully.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:18:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-08-29 15:48:07 EDT
Description of problem:
--------------------------------------------

[root@qeblade30 script]# ./aeolus-upgrade -a
Service 'mongod' can not be running while aeolus-upgrade is in progress
Service 'iwhd' can not be running while aeolus-upgrade is in progress
Service 'postgresql' can not be running while aeolus-upgrade is in progress
Service 'httpd' can not be running while aeolus-upgrade is in progress
Service 'deltacloud-core' can not be running while aeolus-upgrade is in progress
Service 'libvirtd' can not be running while aeolus-upgrade is in progress
Service 'aeolus-conductor' can not be running while aeolus-upgrade is in progress
Service 'conductor-dbomatic' can not be running while aeolus-upgrade is in progress
Service 'imagefactory' can not be running while aeolus-upgrade is in progress
Service 'ntpd' can not be running while aeolus-upgrade is in progress
================================================================================
We will stop all aeolus services using aeolus-services stop.
PROCEED? (y/n): y
aeolus-services: unrecognized service
There was an issue stopping your services. Please resolve this manually
and try again

[root@qeblade30 script]# ll /usr/sbin/aeolus-services
-rwxr-xr-x. 1 root root 2124 Aug 17 13:30 /usr/sbin/aeolus-services
[root@qeblade30 script]# 



Version-Release number of selected component (if applicable):
-------------------------------------------------------------------
aeolus-configure-2.8.2-1.el6cf.noarch
Comment 1 Steve Linabery 2012-08-31 16:20:59 EDT
Not quite sure how to handle this. aeolus-services is provided by aeolus-conductor. aeolus-upgrade isn't really meant to be run without aeolus-conductor package installed.
Comment 2 Steve Linabery 2012-08-31 16:23:04 EDT
please disregard previous comment. aeolus-services is provided by aeolus-configure package.
Comment 4 Steve Linabery 2012-09-06 11:13:18 EDT
4ccb08ead9eabb46b3a41cd2c1d9656f5ad010ad on master, in latest nightly build.
Comment 5 Steve Linabery 2012-09-07 18:02:06 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 6 Steve Linabery 2012-09-07 18:04:20 EDT
setting to MODIFIED so I can attach to ET
Comment 7 Giulio Fidente 2012-09-26 12:35:28 EDT
works with aeolus-conductor-0.13.14-1.el6cf
Comment 9 errata-xmlrpc 2012-12-04 10:18:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.