Bug 853012 - Printing backend is initialized before the winreg pipe is set up.
Printing backend is initialized before the winreg pipe is set up.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba3x (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Guenther Deschner
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 05:24 EDT by Andreas Schneider
Modified: 2013-01-07 22:35 EST (History)
3 users (show)

See Also:
Fixed In Version: samba3x-3.6.6-0.119.el5
Doc Type: Bug Fix
Doc Text:
internal
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:35:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 9122 None None None 2012-08-30 05:24:25 EDT

  None (edit)
Description Andreas Schneider 2012-08-30 05:24:24 EDT
Description of problem:

The printing backend is initialized before we setup the winreg pipe. This means that printing database migration from 3.5 or earlier to 3.6 fails.

We already have a patch which has been tested by Samba customers and confirmed to be working.

THIS IS CRITCAL FOR US!

How reproducible:
Always with Samba 3.6.6.

Steps to Reproduce:
1. Install Samba 3.5.x
2. Create a printer so that you have nt printing databases in /var/lib/samba
3. Stop Samba
4. Install Samba 3.6
5. Start Samba (the printers should automatically be migrated from the nt printing
   database to the samba registry)
Comment 1 RHEL Product and Program Management 2012-08-30 05:27:05 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 RHEL Product and Program Management 2012-08-30 08:07:27 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 13 errata-xmlrpc 2013-01-07 22:35:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0064.html

Note You need to log in before you can comment on or make changes to this bug.