Bug 853044 - [engine-core][TEXT] bad error message when Create Storage Pool fails (host can't reach LUNs)
[engine-core][TEXT] bad error message when Create Storage Pool fails (host ca...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Greg Padgett
Leonid Natapov
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 07:18 EDT by Haim
Modified: 2016-02-10 12:38 EST (History)
10 users (show)

See Also:
Fixed In Version: SI19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm & engine logs (800.00 KB, application/x-tar)
2012-08-30 07:26 EDT, Haim
no flags Details

  None (edit)
Description Haim 2012-08-30 07:18:55 EDT
Description of problem:

please take the following case study: user tries to add a new storage domain, has 2 hosts in its cluster, host A sees the storage, host B doesn't, host A is used to create the storage domain, engine pick host B for the create storage pool, fails, and rollback.

- new domain dialogue, 2 available 
- chose host A 
- login to new target
- mark the new lun 
- hit create 

result: CreateStorageDomain command is send to host A, and succeeds.

since its the first storage domain in pool (uninitialized), engine sends the CreateStoragePool command, but now, to host B, problem is, host B can't see the luns (i.e; connectStorageServer is successful, though it doesn't make sure host indeed see the lun, access list problem), create storage pool fails, user is notified with the following error: Internal oVirt ERROR. 

expected results:

1) connectStorageServer command should be improved (different matter and bug)
2) engine should pick the host that was used to create the storage.
3) error should be improved.
Comment 1 Haim 2012-08-30 07:26:14 EDT
Created attachment 608157 [details]
vdsm & engine logs
Comment 2 Ayal Baron 2012-09-02 11:08:23 EDT
Storage pool requires all hosts in DC to reach the storage domain.
I have no problem with creation failing in this state.
However, the error message should properly explain what the problem is.
Comment 3 Ayal Baron 2012-09-05 06:02:05 EDT
Ack is to fix error message only.
Comment 4 Greg Padgett 2012-09-12 13:59:51 EDT
Patch: http://gerrit.ovirt.org/7968
Comment 6 Greg Padgett 2012-09-19 14:54:38 EDT
Note that reproducing (at least in my case) depended on the order the backend wanted to iterate over the hosts.  It's necessary to choose a host in the new domain dialog with access, and also have the engine choose the /other/ host.  If the engine chooses the wrong host, you may need to switch things up, e.g. instead of blocking storage access from host B and choosing host A, you may need to block storage access from host A and choose host B.
Comment 7 Allon Mureinik 2012-09-24 12:06:06 EDT
merged change id
Comment 8 Leonid Natapov 2012-10-02 07:55:54 EDT
si19. fixed. getting an appropriate error message from the backend engine.

Note You need to log in before you can comment on or make changes to this bug.