Bug 853060 - [RHEVM] [backend] [Host Networking] DC/CL 3.0 cannot change VLAN IP (Previous network name is required.)
[RHEVM] [backend] [Host Networking] DC/CL 3.0 cannot change VLAN IP (Previous...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Moti Asayag
Martin Pavlik
network
: Regression
: 853660 (view as bug list)
Depends On:
Blocks: 850014
  Show dependency treegraph
 
Reported: 2012-08-30 08:17 EDT by Martin Pavlik
Modified: 2016-02-10 14:48 EST (History)
8 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (2.86 KB, application/x-gzip)
2012-08-30 08:17 EDT, Martin Pavlik
no flags Details
screenshot 1 (248.87 KB, image/png)
2012-08-30 08:19 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-08-30 08:17:44 EDT
Created attachment 608173 [details]
engine.log

Description of problem:
DC/CL 3.0 cannot change IP on VLAN interface from none to static IP

	
Error:

dell-r210ii-05.rhev.lab.eng.brq.redhat.com:

    Previous network name is required.


appears

How reproducible:
100%

Steps to Reproduce:
1. Create VLAN assign it to host interface with boot protocol: none
2. Hosts -> your host (in maintanace) -> network interfaces -> pick VLAN interface -> Add/Edit -> boot protol: static -> fill in valid IP/mask -> click OK -> error appears
(see screenshot)
  
Actual results:
Error message appears

Expected results:
IP should be changed

Additional info:

2012-08-30 12:48:39,037 WARN  [org.ovirt.engine.core.bll.UpdateNetworkToVdsInterfaceCommand] (ajp-/127.0.0.1:8009-10) [77573eb4] CanDoAction of action UpdateNetworkToVdsInterface 
failed. Reasons:NETWROK_OLD_NETWORK_NOT_SPECIFIED

There were some bugs with similar error message 
https://bugzilla.redhat.com/buglist.cgi?quicksearch=NETWROK_OLD_NETWORK_NOT_SPECIFIED&list_id=493862
Comment 1 Martin Pavlik 2012-08-30 08:19:42 EDT
Created attachment 608175 [details]
screenshot 1
Comment 2 Moti Asayag 2012-08-30 10:56:47 EDT
The patch-set series which solves bug 850423 also fixed this bug:

http://gerrit.ovirt.org/#/c/7572/
Comment 3 lpeer 2012-09-02 01:15:39 EDT
*** Bug 853660 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.