Bug 853063 - e1000e ethernet driver filters VLANs in promiscous mode
e1000e ethernet driver filters VLANs in promiscous mode
Status: CLOSED DUPLICATE of bug 832573
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dean Nelson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 08:20 EDT by Kontantin Khlebnikov
Modified: 2012-09-06 16:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 16:00:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kontantin Khlebnikov 2012-08-30 08:20:29 EDT
Description of problem:

e1000e driver must disable VLAN filter in promisc mode.
This was broken in rhel 6.3 update. [fix below]

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

--- a/drivers/net/e1000e/netdev.c
+++ b/drivers/net/e1000e/netdev.c
@@ -3205,6 +3205,7 @@ static void e1000e_set_rx_mode(struct net_device *netdev)
 
        if (netdev->flags & IFF_PROMISC) {
                rctl |= (E1000_RCTL_UPE | E1000_RCTL_MPE);
+               rctl &= ~E1000_RCTL_VFE;
        } else {
                int count;
                if (netdev->flags & IFF_ALLMULTI) {
Comment 2 Andy Gospodarek 2012-09-06 16:00:33 EDT

*** This bug has been marked as a duplicate of bug 832573 ***

Note You need to log in before you can comment on or make changes to this bug.