Bug 853090 - not able to remove the --note from repo /repo group etc
not able to remove the --note from repo /repo group etc
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jay Dobies
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 09:26 EDT by Preethi Thomas
Modified: 2013-09-09 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 09:50:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-08-30 09:26:17 EDT
Description of problem:
I have tried the option for repo and repo create, will have verify if the same occurs for cosumer as well.

as per the help for note , it can be removed by specifying  " "

  --note         - adds/updates/deletes key-value pairs to programmatically
                   identify the repository; pairs must be separated by an equal
                   sign (e.g. key=value); multiple notes can be changed by
                   specifying this option multiple times; notes are deleted by
                   specifying "" as the value


But looks like this doesn't work

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

[root@pulp-candidate ~]# pulp-admin repo list
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+


Id:                 zoo
Display Name:       zoo
Description:        None
Content Unit Count: 0
Notes:              
  Repo: zoo


[root@pulp-candidate ~]# pulp-admin repo update --repo-id zoo --note " "
Notes must be specified in the format key=value

[root@pulp-candidate ~]# pulp-admin repo update --repo-id zoo --note ""
Notes must be specified in the format key=value

[root@pulp-candidate ~]# pulp-admin repo update --repo-id zoo --note " "=" "
Repository [zoo] successfully updated

[root@pulp-candidate ~]# pulp-admin repo list
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+




Id:                 zoo
Display Name:       zoo
Description:        None
Content Unit Count: 0
Notes:              
   :     
  Repo: zoo



[root@pulp-candidate ~]# pulp-admin repo group update --group-id  test-grp2  --description "test-group2" --note ""
Notes must be specified in the format key=value

  
Actual results:


Expected results:


Additional info:
Comment 1 Jay Dobies 2012-08-30 09:42:44 EDT
When it says to use "" as the value, it means to still honor the key=value format. You have to specify which note to delete:

--note a=""
or
--note a=

Will delete the note with the key "a".

Moved to ON_QA to verify.
Comment 2 Preethi Thomas 2012-08-30 09:50:29 EDT
verified as not a bug
[root@pulp-candidate ~]# pulp-admin repo group update --group-id test-grp --note group=
Repo group [test-grp] successfully updated

[root@pulp-candidate ~]# pulp-admin repo group list
+----------------------------------------------------------------------+
                           Repository Groups
+----------------------------------------------------------------------+

Id:            pulp
Display Name:  None
Description:   None
Repo Ids:      
Notes:         


Id:            test-grp
Display Name:  test-group
Description:   test-group
Repo Ids:      
Notes:         


Id:            test-grp1
Display Name:  test-group1
Description:   test-group1
Repo Ids:      
Notes:         
  Group1: test1


Id:            test-grp2
Display Name:  None
Description:   test-group2
Repo Ids:      
Notes:         
  Group2:  


[root@pulp-candidate ~]# pulp-admin repo group update --group-id test-grp2 --note group2=""
Repo group [test-grp2] successfully updated

[root@pulp-candidate ~]# pulp-admin repo group list
+----------------------------------------------------------------------+
                           Repository Groups
+----------------------------------------------------------------------+

Id:            pulp
Display Name:  None
Description:   None
Repo Ids:      
Notes:         


Id:            test-grp
Display Name:  test-group
Description:   test-group
Repo Ids:      
Notes:         


Id:            test-grp1
Display Name:  test-group1
Description:   test-group1
Repo Ids:      
Notes:         
  Group1: test1


Id:            test-grp2
Display Name:  None
Description:   test-group2
Repo Ids:      
Notes:         


[root@pulp-candidate ~]#

Note You need to log in before you can comment on or make changes to this bug.