Bug 853126 - add support for vsphere clusters
add support for vsphere clusters
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: imagefactory (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Ian McLeod
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 10:42 EDT by Dave Johnson
Modified: 2012-12-04 10:18 EST (History)
3 users (show)

See Also:
Fixed In Version: imagefactory-1.0.2-1.el6cf
Doc Type: Bug Fix
Doc Text:
Using a vSphere environment with clustering caused errors when pushing images in Cloud Engine. This fix adds "host" or "computeresource" fields in the provider definition. Cloud Engine users are now able to push images to a vSphere environment with clustering.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:18:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-08-30 10:42:39 EDT
Description of problem:
==============================
If you configure imagefactory to use a vsphere environment that is setup for clustering, errors occur during the push and result in failure.


Version-Release number of selected component (if applicable):
===================================================================
v1.0.1
Comment 1 Ian McLeod 2012-09-11 18:59:04 EDT
A fix for this is currently brewing as imagefactory 1.0.2-1.

It allows you to add a "host" or "computeresource" field in the provider definition JSON.  This includes ClusterComputeResource(s) or hosts that are part of them.
Comment 3 Giulio Fidente 2012-10-25 05:26:04 EDT
works for me on puddle #6
Comment 5 errata-xmlrpc 2012-12-04 10:18:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.