Bug 853190 - binaries in /sbin rely on libraries in /usr
binaries in /sbin rely on libraries in /usr
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnbd (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ben Marzinski
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 12:58 EDT by Nate Straz
Modified: 2012-09-07 18:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 18:06:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2012-08-30 12:58:06 EDT
Description of problem:

Since the last time gnbd had an errata (RHEL-5.3.0), a test was added to check if binaries in /bin or /sbin are using libraries in /usr.  TPS found several such binaries in gnbd.


/sbin/gnbd_clusterd relies on libs in /usr: libcman.so.2
/sbin/gnbd_export relies on libs in /usr: libcman.so.2
/sbin/gnbd_import relies on libs in /usr: libcman.so.2
/sbin/gnbd_monitor relies on libs in /usr: libcman.so.2
/sbin/gnbd_recvd relies on libs in /usr: libcman.so.2
/sbin/gnbd_serv relies on libs in /usr: libcman.so.2
SharedLibTest: 7 regular binaries and 7 debug files were found.

Version-Release number of selected component (if applicable):
gnbd-1.1.7-2.el5

How reproducible:
100%

Steps to Reproduce:
Run TPS
or 
ldd /sbin/gnbd_import

  
Actual results:


Expected results:


Additional info:
Comment 1 Ben Marzinski 2012-09-07 18:06:47 EDT
This package doesn't exist in RHEL6 or forward.  The binaries have always been located in /sbin, and changing the location of them at this point in RHEL5 is not worth the associated risk of breaking customer's setups.

Note You need to log in before you can comment on or make changes to this bug.