Bug 853306 - cpu usage is high while guest is in safe mode
cpu usage is high while guest is in safe mode
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 22:41 EDT by Suqin Huang
Modified: 2014-09-11 05:48 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-11 05:15:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2012-08-30 22:41:51 EDT
Description of problem:
Press F8 and enter Save model, cpu usage is high

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. cmd
/usr/libexec/qemu-kvm -drive file=/home/winXP-32-virtio.qcow2,if=none,id=virtio-disk1,media=disk,aio=threads,cache=none,format=qcow2 -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=virtio-disk1,id=virtio1 -device rtl8139,netdev=idG74fKJ,mac=9a:a6:40:72:d0:c5,id=ndev00idG74fKJ,bus=pci.0,addr=0x3 -netdev tap,id=idG74fKJ,vhost=on,script=/home/autotest-devel/client/tests/kvm/scripts/qemu-ifup-switch -m 4096 -smp 2,cores=1,threads=1,sockets=2 -cpu 'Opteron_G3' -vnc :0 -vga std -rtc base=utc,clock=host,driftfix=slew -M rhel6.3.0 -boot order=cdn,once=c,menu=off -no-kvm-pit-reinjection -monitor stdio

2. Press F8 and enter save model
3.
  
Actual results:


Expected results:


Additional info:
1. kvm_stat:
kvm statistics

 efer_reload                  0       0
 exits                  9309221    3153
 fpu_reload             1524738     382
 halt_exits                1273       0
 halt_wakeup               1243       0
 host_state_reload	2282478     382
 hypercalls               74557      18
 insn_emulation         1635667     325
 insn_emulation_fail          0       0
 invlpg                       0       0
 io_exits                830377     324
 irq_exits              6460556    2352
 irq_injections          272620     149
 irq_window                   0       0
 largepages                2423       0
 mmio_exits              372137       0
 mmu_cache_miss             438       0
 mmu_flooded                  0       0
 mmu_pde_zapped               0       0
 mmu_pte_updated              0       0
 mmu_pte_write                2       0
 mmu_recycled                 0       0

2. top
 PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                    
 3974 root      20   0 4514m 3.5g 4344 R 99.9 47.6  19:32.71 qemu-kvm                                   
 3976 root      20   0 4514m 3.5g 4344 R 99.9 47.6  19:27.02 qemu-kvm                                   
 3960 root      20   0 4514m 3.5g 4344 S  0.7 47.6   0:10.05 qemu-kvm 

3. guest: winxp

4. host:
processor	: 3
vendor_id	: AuthenticAMD
cpu family	: 16
model		: 2
model name	: AMD Phenom(tm) 9600B Quad-Core Processor
stepping	: 3
cpu MHz		: 2300.000
cache size	: 512 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 3
initial apicid	: 3
fpu		: yes
fpu_exception	: yes
cpuid level	: 5
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs npt lbrv svm_lock
bogomips	: 4587.96
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate
Comment 2 Ademar Reis 2012-08-31 10:32:08 EDT
I don't understand what "save model" would be (after pressing f8). Since it's a windows guest, I guess you mean "safe mode", which is a boot mode in Windows XP, and "press f8" means "press f8 inside the guest when windows begins to boot".

Please try something similar with a newer version of Windows (tests with win7-32 and win7-64 would be very welcome).
Comment 3 Suqin Huang 2012-09-04 22:55:27 EDT
(In reply to comment #2)
> I don't understand what "save model" would be (after pressing f8). Since
> it's a windows guest, I guess you mean "safe mode", which is a boot mode in
> Windows XP, and "press f8" means "press f8 inside the guest when windows
> begins to boot".

sorry, it's safe mode
> 
> Please try something similar with a newer version of Windows (tests with
> win7-32 and win7-64 would be very welcome).

can not enter safe mode with other guests(win7 and win2008)
Comment 5 Suqin Huang 2012-09-23 22:36:22 EDT
no, reproduce on qemu-kvm-0.12.1.2-2.295.el6.x86_64
Comment 6 Ronen Hod 2012-09-24 04:30:26 EDT
IIUC, this is not a regression, so postponing to 6.5
Comment 8 Ronen Hod 2013-05-21 09:57:54 EDT
QE,
We suspect that this is a Windows issue (especially as a guest). Is there an option to do the same with Hyper-V instead of KVM?
Comment 10 juzhang 2014-06-09 22:24:06 EDT
(In reply to Ronen Hod from comment #8)
> QE,
> We suspect that this is a Windows issue (especially as a guest). Is there an
> option to do the same with Hyper-V instead of KVM?

Hi Lei,

Seems a little old needinfo.

Could you please let your team have a look and give some testing if possible? Thanks

Best Regards,
Junyi
Comment 13 Lei Wang 2014-09-11 02:32:09 EDT
(In reply to juzhang from comment #10)
> (In reply to Ronen Hod from comment #8)
> > QE,
> > We suspect that this is a Windows issue (especially as a guest). Is there an
> > option to do the same with Hyper-V instead of KVM?
> 
> Hi Lei,
> 
> Seems a little old needinfo.
> 
> Could you please let your team have a look and give some testing if
> possible? Thanks
> 
> Best Regards,
> Junyi

Apologize for the late response Junyi, I've talked with shwang@ regarding the test request, please let us know what exacat senarios you'd like us to have a try, thanks.
Comment 16 Ronen Hod 2014-09-11 05:15:41 EDT
(In reply to Qian Guo from comment #14)
> And only can reproduce it with windows xp guest
> 
> Test windows7 32bit and windows7 64bit sp1 in safe mode, not hit such issue

Thanks a lot.
I am closing this bug. We are only dealing with very critical XP-specific bugs.
Ronen.

Note You need to log in before you can comment on or make changes to this bug.