Bug 853325 - qemu candidate rpm does not build on ppc (and probably other platforms)
qemu candidate rpm does not build on ppc (and probably other platforms)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
18
ppc Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 01:09 EDT by David Gibson
Modified: 2013-01-09 07:07 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 02:04:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Gibson 2012-08-31 01:09:01 EDT
Description of problem:

The current candidate ppc64 package for qemu, which is in koji at http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=105383 does not build.

There are duplicate incompatible definitions of the function kvm_irqchip_commit_routes().  This isn't technically a ppc specific bug, but it is masked on x86 because the code path that triggers this is never touched.

This bug is already fixed in the upstream qemu-kvm tree (including qemu-kvm-1.2.0-rc1).
Comment 1 David Gibson 2012-09-07 02:04:42 EDT
Ok, newer F18 SRPMs build, they just need to be built for ppc. Closing.

Note You need to log in before you can comment on or make changes to this bug.