Bug 853326 - /etc/X11/xinit/xinput.d/im-cedilla.conf confilics between gtk2-immodules and gtk3
/etc/X11/xinit/xinput.d/im-cedilla.conf confilics between gtk2-immodules and ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
18
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 01:10 EDT by sangu
Modified: 2014-02-05 07:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 07:07:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2012-08-31 01:10:45 EDT
Description of problem:
# yum update gtk2
[...]
Transaction Check Error:
  file /etc/X11/xinit/xinput.d/im-cedilla.conf from install of gtk2-immodules-2.24.11-2.fc18.x86_64 conflicts with file from package gtk3-3.5.12-2.fc18.x86_64



Version-Release number of selected component (if applicable):
2.24.11-2.fc18

How reproducible:
always

Steps to Reproduce:
1. yum update gtk2
2.
3.
  
Actual results:


Expected results:


Additional info:
gtk3-3.5.12-2.fc18.x86_64
Comment 1 ZiN 2013-03-02 15:40:38 EST
  file /etc/X11/xinit/xinput.d/im-cedilla.conf from install of gtk2-immodules-2.24.16-1.fc18.i686 conflicts with file from package gtk3-3.6.4-1.fc18.i686
Comment 2 valtestad 2013-03-09 14:40:10 EST
This is more serious problem than just updating gtk2 as it happens on 'yum update'. The im-cedilla.conf conflict causes yum update to fail and the rest of the updates not to be applied to the whole system. As the system update is a vital necessity for its proper function - the bug severity needs to be elevated and the problem to be fixed rather sooner than later.
Comment 3 Ankur Sinha (FranciscoD) 2013-03-29 23:51:11 EDT
It appears to be a packaging bug. The file is owned by two packages? gtk3 and gtk2-immodules.

[root@localhost ~]# yum whatprovides '/etc/X11/xinit/xinput.d/im-cedilla.conf'
Loaded plugins: changelog, langpacks, merge-conf, presto, refresh-packagekit
gtk2-immodules-2.24.13-1.fc18.i686 : Input methods for GTK+
Repo        : fedora
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk2-immodules-2.24.13-1.fc18.i686 : Input methods for GTK+
Repo        : updates-testing
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk2-immodules-2.24.13-1.fc18.x86_64 : Input methods for GTK+
Repo        : fedora
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk2-immodules-2.24.13-1.fc18.x86_64 : Input methods for GTK+
Repo        : updates-testing
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk2-immodules-2.24.16-1.fc18.i686 : Input methods for GTK+
Repo        : updates
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk2-immodules-2.24.16-1.fc18.x86_64 : Input methods for GTK+
Repo        : updates
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk3-3.6.2-1.fc18.i686 : The GIMP ToolKit (GTK+), a library for creating GUIs for X
Repo        : fedora
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk3-3.6.2-1.fc18.i686 : The GIMP ToolKit (GTK+), a library for creating GUIs for X
Repo        : updates-testing
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk3-3.6.2-1.fc18.x86_64 : The GIMP ToolKit (GTK+), a library for creating GUIs for X
Repo        : fedora
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk3-3.6.2-1.fc18.x86_64 : The GIMP ToolKit (GTK+), a library for creating GUIs for X
Repo        : updates-testing
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk3-3.6.4-1.fc18.i686 : The GIMP ToolKit (GTK+), a library for creating GUIs for X
Repo        : updates
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk3-3.6.4-1.fc18.x86_64 : The GIMP ToolKit (GTK+), a library for creating GUIs for X
Repo        : updates
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk3-3.6.4-1.fc18.i686 : The GIMP ToolKit (GTK+), a library for creating GUIs for X
Repo        : @updates
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf



gtk3-3.6.4-1.fc18.x86_64 : The GIMP ToolKit (GTK+), a library for creating GUIs for X
Repo        : @updates-testing
Matched from:
Filename    : /etc/X11/xinit/xinput.d/im-cedilla.conf
Comment 4 valtestad 2013-07-12 02:28:33 EDT
it does not look like this bug going to be ever fixed. is there any other solution, e.g. removing gtk* and then updating gtk3 (i don't pretend i know the subject deep enough, so pls don't judge me), etc. I have this issue blocking me from installing Skype as it needs qtwebkit.i686. Also, would this problem affect fedup to F19? Please enlighten!
Comment 5 valtestad 2013-07-12 04:06:59 EDT
the workaround that helped me:
yum remove gtk2-immodules-2.24.13-1.fc18.x86_64
yum update
Comment 6 Fedora End Of Life 2013-12-21 03:49:26 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Fedora End Of Life 2014-02-05 07:07:21 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.