Bug 853352 - spinner does not stop when wrong user/pass is entered on login
spinner does not stop when wrong user/pass is entered on login
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Garik Khachikyan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 04:17 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 11:21:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failed login (37.51 KB, image/png)
2012-08-31 04:17 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2012-08-31 04:17:08 EDT
Created attachment 608415 [details]
failed login

Description of problem:
In recent Katello UI the spinner does stay loaded even after red alert popup telling:
"You have entered an incorrect username/password combination, or your account may currently be disabled. Please try again or contact your administrator."

Version-Release number of selected component (if applicable):
candlepin-0.7.7.1-1.el6.noarch
katello-glue-candlepin-1.1.8-1.el6.noarch
pulp-common-1.1.12-1.el6.noarch
katello-selinux-1.1.1-1.el6.noarch
qpid-cpp-client-0.14-16.el6.x86_64
qpid-cpp-client-ssl-0.14-16.el6.x86_64
python-oauth2-1.5.170-2.pulp.el6.noarch
pulp-selinux-server-1.1.12-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
qpid-cpp-server-ssl-0.14-16.el6.x86_64
python-qpid-0.14-8.el6.noarch
katello-agent-1.1.2-1.el6.noarch
katello-certs-tools-1.1.8-1.el6.noarch
katello-glue-foreman-1.1.8-1.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
pulp-1.1.12-1.el6.noarch
katello-all-1.1.8-1.el6.noarch
katello-repos-1.1.2-1.el6.noarch
qpid-cpp-server-0.14-16.el6.x86_64
katello-common-1.1.8-1.el6.noarch
katello-configure-1.1.6-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
candlepin-selinux-0.7.7.1-1.el6.noarch
katello-glue-pulp-1.1.8-1.el6.noarch
candlepin-tomcat6-0.7.7.1-1.el6.noarch
katello-1.1.8-1.el6.noarch
katello-cli-common-1.1.4-1.git.12.9f57f86.el6.noarch
katello-cli-1.1.4-1.git.12.9f57f86.el6.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.try to login to Katello UI with wrong username / password.
2.
3.
  
Actual results:
the spinner does remain on loading state.

Expected results:
Spinner disappears, red alert pops up.

Additional info:
See screenshot attached
Comment 3 Mike McCune 2012-10-17 11:21:59 EDT
this is functional and also fixed in 1.1, feel free to reopen if it still happens
Comment 4 Mike McCune 2013-08-16 13:56:09 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.