Bug 853361 - [PATCH] Please make wireshark.spec of 1.8+ compatible with RHEL6/gtk2 again
[PATCH] Please make wireshark.spec of 1.8+ compatible with RHEL6/gtk2 again
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
rawhide
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 04:43 EDT by David Jaša
Modified: 2012-09-04 11:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: wireshark-1.8.2-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 11:06:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec patch (2.12 KB, patch)
2012-08-31 04:43 EDT, David Jaša
no flags Details | Diff
spec patch (2.03 KB, patch)
2012-08-31 07:59 EDT, David Jaša
no flags Details | Diff

  None (edit)
Description David Jaša 2012-08-31 04:43:18 EDT
Created attachment 608435 [details]
spec patch

Description of problem:
Please make wireshark.spec RHEL6/gtk2-compatible. I need to use Wireshark 1.7+ in RHEL and few changes like the ones in attached patch make it significantly easier, to the point of just adding epel repos, installing build dependencies and calling rpmbuild --rebuild wireshark-v-r.src.rpm

All the changes shouldn't affect build on Fedora at all (tested on fc17)

Version-Release number of selected component (if applicable):
wireshark-1.8.2-1
Comment 1 David Jaša 2012-08-31 07:59:35 EDT
Created attachment 608496 [details]
spec patch

gtk2/3 hard dependency re-added, package depends on the same soname when build on RHEL 6 and Fedora 17.

Note You need to log in before you can comment on or make changes to this bug.