Bug 853371 - Run CLI virt-who in debug mode will report "ERROR: Unable to create connection:" and can't recover connection
Run CLI virt-who in debug mode will report "ERROR: Unable to create connecti...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity high
: beta
: ---
Assigned To: Radek Novacek
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 05:26 EDT by Hui Wang
Modified: 2016-11-30 19:30 EST (History)
1 user (show)

See Also:
Fixed In Version: virt-who-0.7-5.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:36:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2012-08-31 05:26:47 EDT
Description of problem:
Run virt-who -d, it will report "ERROR: Unable to create connection:", but if run service virt-who, it will can connect with server and will report the right guest uuids.

Version-Release number of selected component (if applicable):

virt-who-0.7-4.el5
libvirt-0.8.2-29.el5
libvirt-python-0.8.2-29.el5
libvirt-cim-0.5.8-3.el5
python-rhsm-1.0.6-1.el5
subscription-manager-1.0.14-1.el5

How reproducible:
100%

Steps to Reproduce:
1. Register host to SAM
2. Install some guests on host
3. Run CLI virt-who -d
 [root@amd-8750-4-1 ~]# virt-who -d
WARNING: Listening for events is not available in VDSM or ESX mode
DEBUG: Virt-who is running in libvirt mode
DEBUG: Starting infinite loop with 3600 seconds interval
ERROR: Unable to create connection:
Traceback (most recent call last):
  File "/usr/share/virt-who/virt-who.py", line 161, in _send
    self.checkConnections()
  File "/usr/share/virt-who/virt-who.py", line 140, in checkConnections
    self.initVirt()
  File "/usr/share/virt-who/virt-who.py", line 95, in initVirt
    self.virt = Virt(self.logger, registerEvents=not self.options.oneshot)
  File "/usr/share/virt-who/virt.py", line 42, in __init__
    raise VirtError(str(e))
VirtError: this function is not supported by the connection driver: xenUnifiedDomainEventRegister
ERROR: Unable to recover, retry in 60 seconds.
ERROR: Unable to create connection:
Traceback (most recent call last):
  File "/usr/share/virt-who/virt-who.py", line 161, in _send
    self.checkConnections()
  File "/usr/share/virt-who/virt-who.py", line 140, in checkConnections
    self.initVirt()
  File "/usr/share/virt-who/virt-who.py", line 95, in initVirt
    self.virt = Virt(self.logger, registerEvents=not self.options.oneshot)
  File "/usr/share/virt-who/virt.py", line 42, in __init__
    raise VirtError(str(e))
VirtError: this function is not supported by the connection driver: xenUnifiedDomainEventRegister
ERROR: Unable to recover, retry in 60 seconds.
 
Actual results:
Will report: "ERROR: Unable to create connection:" and and can't recover connection

Expected results:
Do not report:"ERROR: Unable to create connection:" or can recover connection


Additional info:

But use service virt-who will report the guest uuids
Enble VIRTWHO_DEBUG in /etc/sysconfig/virt-who

root@amd-8750-4-1 ~]# service virt-who restart
Stopping virt-who:                                         [FAILED]
Starting virt-who: 
                                        [  OK  ]
[root@amd-8750-4-1 ~]# tail -f /var/log/rhsm/rhsm.log
2012-08-31 05:07:46,812 [DEBUG]  @virt.py:62 - Virtual machine found: test: b83cf771-fc48-db4b-e66c-586ab00aa9d7
2012-08-31 05:07:46,816 [DEBUG]  @virt.py:62 - Virtual machine found: 6.3_Server_x86_64_FV: aaa3df8b-934a-25c5-576c-137ed0e0bfa4
2012-08-31 05:07:46,820 [DEBUG]  @virt.py:62 - Virtual machine found: 6.2_Server_x86_64_PV: d75178e2-bf31-0559-15a4-b39a3251af43
2012-08-31 05:07:46,824 [DEBUG]  @virt.py:62 - Virtual machine found: 5.8_Server_x86_64_FV: 00d608f7-27b6-b06e-3cde-99df12b030a2
2012-08-31 05:07:46,828 [DEBUG]  @virt.py:62 - Virtual machine found: 6.2_Client_i386_FV: 26dc37dc-a7eb-ef91-435f-43e106df7526
2012-08-31 05:07:46,832 [DEBUG]  @virt.py:62 - Virtual machine found: 6.3_Client_i386_FV: 916f7602-93c6-30ab-6d10-6fbb74ac1466
2012-08-31 05:07:46,836 [DEBUG]  @virt.py:62 - Virtual machine found: 5.8_Client_i386_PV: c80de70a-4d27-67b3-d706-c98047585b91
2012-08-31 05:07:46,840 [DEBUG]  @virt.py:62 - Virtual machine found: 5.8_Server_x86_64_PV: 7cc6a77c-5b9e-bf11-ccd9-6b857ffce55c
2012-08-31 05:07:46,844 [DEBUG]  @virt.py:62 - Virtual machine found: 6.2_Server_x86_64_FV: d1c45dcf-b209-1879-29b6-e46ab7a821aa
2012-08-31 05:07:46,845 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['00d608f7-27b6-b06e-3cde-99df12b030a2', '26dc37dc-a7eb-ef91-435f-43e106df7526', '4c67eea4-a82b-4e69-1c08-ce37f67837f4', '581cee95-9f8d-5626-bf45-eaebdec0d408', '7bbf24d8-03f2-e493-5aa9-0aaa8042c8fd', '7cc6a77c-5b9e-bf11-ccd9-6b857ffce55c', '916f7602-93c6-30ab-6d10-6fbb74ac1466', 'aaa3df8b-934a-25c5-576c-137ed0e0bfa4', 'b83cf771-fc48-db4b-e66c-586ab00aa9d7', 'c80de70a-4d27-67b3-d706-c98047585b91', 'd1c45dcf-b209-1879-29b6-e46ab7a821aa', 'd75178e2-bf31-0559-15a4-b39a3251af43', 'eb5b2200-cf4c-ac3d-0ac3-184353fa328c']
Comment 1 RHEL Product and Program Management 2012-08-31 05:28:34 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 RHEL Product and Program Management 2012-08-31 05:48:18 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Radek Novacek 2012-09-03 07:18:40 EDT
This bug should be fixed in virt-who-0.7-5.el5.
Comment 5 Hui Wang 2012-09-05 03:14:20 EDT
The issue fixed. Moving to Verified.

Version:
virt-who-0.7-5.el5
libvirt-0.8.2-29.el5
libvirt-python-0.8.2-29.el5
libvirt-cim-0.5.8-3.el5
python-rhsm-1.0.6-1.el5
subscription-manager-1.0.14-1.el5

steps:
1. Register host to SAM
2. Install some guests on host
3. Run CLI virt-who -d
[root@amd-5400b-4-4 home]# virt-who -d
WARNING: Listening for events is not available in VDSM or ESX mode
DEBUG: Virt-who is running in libvirt mode
DEBUG: Starting infinite loop with 3600 seconds interval
DEBUG: Virtual machine found: 5.8_Server_x86_64: 26bf6b1d-e6fc-29ed-3d8c-bb89f15f3e77
DEBUG: Sending list of uuids: ['26bf6b1d-e6fc-29ed-3d8c-bb89f15f3e77']
Comment 7 errata-xmlrpc 2013-01-08 02:36:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0072.html

Note You need to log in before you can comment on or make changes to this bug.