Bug 853401 - kdump printing confusing message in kdump kernel when capturing a ELF format vmcore
kdump printing confusing message in kdump kernel when capturing a ELF format ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.9
All Linux
high Severity high
: rc
: ---
Assigned To: Baoquan He
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 08:07 EDT by Guangze Bai
Modified: 2015-02-08 16:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-16 21:08:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guangze Bai 2012-08-31 08:07:06 EDT
Description of problem:

As this bug title said, here is an example:

<snip>
mapping eth0 to eth0
bnx2 0000:03:00.0: eth0: using MSIX
udhcpc (v1.2.0) started
udhcpc[1119]: udhcpc (v1.2.0) started
Sending discover...
udhcpc[1119]: Sending discover...
Sending discover...
udhcpc[1119]: Sending discover...
bnx2 0000:03:00.0: eth0: NIC Copper Link is Up, 1000 Mbps full duplex
Sending discover...
udhcpc[1119]: Sending discover...
Sending select for 10.66.86.55...
udhcpc[1119]: Sending select for 10.66.86.55...
Lease of 10.66.86.55 obtained, lease time 43200
udhcpc[1119]: Lease of 10.66.86.55 obtained, lease time 43200
deleting routers
adding dns 10.66.191.13
adding dns 10.66.127.10
adding dns 172.16.52.28
Saving to remote location storageqe-52.rhts.eng.nay.redhat.com:/mnt
[100 %]

The dumpfile is saved to /mnt//var/crash/10.66.86.55-2012-08-31-07:07:05/vmcore-incomplete.              <----

makedumpfile Completed.
Saving core complete
md: stopping all md devices.
Restarting system.
.
machine restart
</snip>

Please note the arrow line:
it should print the dumpfile saved to storageqe-52.rhts.eng.nay.redhat.com:/mnt instead of the mount point. Also, the dump process goes 100% and indeed vmcore file is good to use in nfs server side, but the printing said vmcore-incomplete, odd!

Version-Release number of selected component (if applicable):
-159 kexec-tools

How reproducible:
always

Steps to Reproduce:
1. # grep -v ^# /etc/kdump.conf
core_collector makedumpfile -E -d 1
default shell
net storageqe-52.rhts.eng.nay.redhat.com:/mnt

2. echo c > /proc/sysrq-trigger

Additional info:
Comment 2 RHEL Product and Program Management 2012-08-31 08:28:21 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Dave Young 2012-09-13 01:13:41 EDT
Hi,

This message is printed by makedumpfile itself. we call makedumpfile vmcore /var/crash/vmcore-complete, so it prints this sentence.

From perspective of makedumpfile, it's not a bug. From kdump side of view, it can be workaround by using --message-level x-2, such as originally you use '--message-level 31', you can select to use '--message-level 29' to mutt it.

I would like to close this as WONTFIX..
Comment 7 RHEL Product and Program Management 2012-10-30 02:01:57 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.