Bug 853437 - updating dnsmasq overwrites dnsmasq.service
updating dnsmasq overwrites dnsmasq.service
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnsmasq (Show other bugs)
17
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 09:59 EDT by Gene Czarcinski
Modified: 2012-11-13 08:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 08:11:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2012-08-31 09:59:39 EDT
Description of problem:
The regular practice is to use %config(noreplace) for configuration files going into /etc/ ... well, the dnsmasq.service file is also a configuration file since runtime parameters can be specified in a conf file or on the command line or both.

Version-Release number of selected component (if applicable):
Fedora 17, dnsmasq-2.59-5.fc17

How reproducible:
yes.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
dnsmasq.service file is overwritten

Expected results:
not overwritten

Additional info:
Comment 1 Fedora Admin XMLRPC Client 2012-10-22 09:20:55 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Tomáš Hozza 2012-11-13 08:11:29 EST
Please read Packaging guidelines regarding the Systemd:
https://fedoraproject.org/wiki/Packaging:Systemd#.25files_section

Systemd unit .service files must not be marked as %config files. If the user wants to reconfigure a .service file he should copy the .service file from /lib/systemd/system to /etc/systemd/system and edit it there. Unit files in /etc/systemd/system override those in /lib/systemd/system if they carry the same name.

Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.