Bug 853441 - trace-back upon adding packages to deletion changeset
trace-back upon adding packages to deletion changeset
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Mike McCune
Kedar Bidarkar
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 10:06 EDT by Kedar Bidarkar
Modified: 2014-03-18 13:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kedar Bidarkar 2012-08-31 10:06:11 EDT
Description of problem:

trace-back upon adding packages to deletion changeset


Failed to delete changeset 'pack_deletion-changeset'. Check notices for more details
progresstask_owner_typecreated_atuuid96ee7091-f373-11e1-bc72-5254001e073cresulterrorsMetadata for repo [redhat-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server] is set to be preserved. Cannot re-generate metadataTraceback (most recent call last): File "/usr/lib/python2.6/site-packages/pulp/server/tasking/task.py", line 418, in run result = self.callable(*self.args, **self.kwargs) File "/usr/lib/python2.6/site-packages/pulp/server/api/repo.py", line 2286, in _generate_metadata raise PulpException(msg) PulpException: Metadata for repo [redhat-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server] is set to be preserved. Cannot re-generate metadata pending?falsetask_typeorganization_idfinish_time2012-08-31 13:55:58user_id0updated_atstateerrortask_owner_idparametersstart_time (RuntimeError)


2012-08-31 19:24:12,998 3723:140334969386752: pulp.server.api.repo:ERROR: repo:2192 Unable to find package id for filename=389-ds-base-1.2.10.2-18.el6_3.x86_64.rpm, checksum=c11260d135b2a597fc81a8f0fce9ef81ca355edb
2012-08-31 19:24:13,032 3723:140334969386752: pulp.server.api.repo:ERROR: repo:2192 Unable to find package id for filename=389-ds-base-1.2.10.2-20.el6_3.x86_64.rpm, checksum=30b9345e86866da61a99c21d0037d84198298d20
2012-08-31 19:24:13,033 3723:140334969386752: pulp.server.api.repo:INFO: repo:2208 Translated 2 filename,checksums in 0.0808589458466 seconds
2012-08-31 19:25:58,335 3723:140334545753856: pulp.server.api.repo:INFO: repo:2285 Metadata for repo [redhat-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server] is set to be preserved. Cannot re-generate metadata
2012-08-31 19:25:58,384 3723:140334545753856: pulp.server.tasking.task:ERROR: task:472 Task failed: Task 96ee7091-f373-11e1-bc72-5254001e073c: RepoApi._generate_metadata(redhat-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server, )
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/tasking/task.py", line 418, in run
    result = self.callable(*self.args, **self.kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/repo.py", line 2286, in _generate_metadata
    raise PulpException(msg)
PulpException: Metadata for repo [redhat-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server] is set to be preserved. Cannot re-generate metadata



Version-Release number of selected component (if applicable):

Katello Version: 1.1.7-1.git.176.aad354c.el6

How reproducible:

Try adding packages to a deletion changeset

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Packages don't seem to get deleted, upon adding to deletion changeset.

Expected results:
Packages should get deleted from the repo, upon adding to the deletion changeset.


Additional info:
Comment 2 Mike McCune 2012-10-24 12:21:07 EDT
this appears to work fine now, please re-open if it is occurring again
Comment 3 Kedar Bidarkar 2012-10-30 10:14:40 EDT
Tried adding packages to deletion changeset, but it failed, with the below error.

It's same for both RedHat Content as well as Custom Content.

tail -f /var/log/pulp/pulp.log
2012-10-30 18:40:16,514 32691:140360057612032: pulp.server.tasking.task:INFO: task:454 Task succeeded: Task 1e84fbde-2293-11e2-88b2-525400c7bf3a: RepoApi._generate_metadata(redhat-rhcf-cfse, )
2012-10-30 18:42:22,480 32691:140360315557632: pulp.server.api.repo:ERROR: repo:2192 Unable to find package id for filename=katello-cli-common-1.1.8-10.el6cf.noarch.rpm, checksum=500017a02abcaf6be762ca7e948ec5277d7674ae
2012-10-30 18:42:22,480 32691:140360315557632: pulp.server.api.repo:ERROR: repo:2192 Unable to find package id for filename=katello-cli-1.1.8-10.el6cf.noarch.rpm, checksum=f1ebfbef1c873c00032465d4273f0976b79c0f6b
2012-10-30 18:42:22,480 32691:140360315557632: pulp.server.api.repo:INFO: repo:2208 Translated 2 filename,checksums in 0.00145888328552 seconds
2012-10-30 18:42:23,939 32691:140360057612032: pulp.server.api.repo:INFO: repo:2291 Spawning repo metadata generation for repo [redhat-Dev-rhcf-cfse] with path [/var/lib/pulp//repos/redhat/Dev/custom/rhcf/cfse]
2012-10-30 18:42:23,939 32691:140360057612032: pulp.server.util:INFO: util:507 metadata found; taking backup.
2012-10-30 18:42:23,980 32691:140360057612032: pulp.server.util:INFO: util:467 Checking what metadata types are available: ['filelists', 'primary', 'primary_db', 'other_db', 'other', 'filelists_db']
2012-10-30 18:42:23,981 32691:140360057612032: pulp.server.util:INFO: util:489 started repo metadata update: ['createrepo', '--database', '--checksum', 'sha', '--update', '/var/lib/pulp//repos/redhat/Dev/custom/rhcf/cfse']
2012-10-30 18:42:36,733 32691:140360057612032: pulp.server.util:INFO: util:542 createrepo on /var/lib/pulp//repos/redhat/Dev/custom/rhcf/cfse finished
2012-10-30 18:42:36,735 32691:140360057612032: pulp.server.tasking.task:INFO: task:454 Task succeeded: Task 71cc2845-2293-11e2-aa77-525400c7bf3a: RepoApi._generate_metadata(redhat-Dev-rhcf-cfse, )
2012-10-30 18:55:59,115 32691:140360449775360: pulp.server.api.repo:ERROR: repo:2192 Unable to find package id for filename=zsh-4.3.10-5.el6.i686.rpm, checksum=a083b24a540f0911da61f453a7a260dc1c5404ea
2012-10-30 18:55:59,145 32691:140360449775360: pulp.server.api.repo:ERROR: repo:2192 Unable to find package id for filename=zsh-4.3.10-4.1.el6.i686.rpm, checksum=b1f313882424f9b6ec83c105b76d7d2739584cde
2012-10-30 18:55:59,146 32691:140360449775360: pulp.server.api.repo:INFO: repo:2208 Translated 2 filename,checksums in 0.0891618728638 seconds
2012-10-30 18:57:34,069 32691:140360057612032: pulp.server.api.repo:INFO: repo:2291 Spawning repo metadata generation for repo [redhat-Dev-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_i386_6Server] with path [/var/lib/pulp//repos/redhat/Dev/content/dist/rhel/server/6/6Server/i386/os]
2012-10-30 18:57:34,286 32691:140360057612032: pulp.server.util:INFO: util:507 metadata found; taking backup.
2012-10-30 18:57:39,640 32691:140360057612032: pulp.server.util:INFO: util:467 Checking what metadata types are available: ['group', 'filelists', 'updateinfo', 'group_gz', 'primary', 'primary_db', 'other_db', 'other', 'filelists_db', 'productid']
2012-10-30 18:57:39,687 32691:140360057612032: pulp.server.util:INFO: util:489 started repo metadata update: ['createrepo', '--database', '--checksum', 'sha', '-g', '/var/lib/pulp//repos/redhat/Dev/content/dist/rhel/server/6/6Server/i386/os/repodata/comps.xml', '--update', '/var/lib/pulp//repos/redhat/Dev/content/dist/rhel/server/6/6Server/i386/os']
Comment 4 Corey Welton 2012-10-30 10:23:23 EDT
This may be the web front-end complement to bug #855146
Comment 5 Kedar Bidarkar 2012-11-01 07:40:06 EDT
Also I guess, this bug and https://bugzilla.redhat.com/show_bug.cgi?id=853445 can be addressed together and may be linked.

Bug 853445 (trace-back upon adding ERRATA to deletion changeset)
Comment 6 Kedar Bidarkar 2012-11-12 07:03:43 EST
Was unable to add both the i386 and x86_64 versions of zsh to the deletion changeset.

Got the error: 
Validation Failed:
 Nvrea has already been taken.

Will be attaching the screeshot shortly.

On Proceeding ahead with just the i386 version of the packages, face the same issue as earlier.

2012-11-12 17:03:16,411 32627:140649615550208: pulp.repo_auth.repo_cert_utils:INFO: repo_cert_utils:112 Deleting certificate bundles at [/etc/pki/pulp/content/redhat-Dev-Red_Hat_Enterprise_Linux_Server-Red_Hat_CloudForms_Tools_for_RHEL_6_RPMs_i386_6Server]
2012-11-12 17:03:16,521 32627:140649615550208: pulp.server.tasking.task:INFO: task:454 Task succeeded: Task bfb31621-2cbc-11e2-92e3-525400c7bf3a: RepoApi.delete(redhat-Dev-Red_Hat_Enterprise_Linux_Server-Red_Hat_CloudForms_Tools_for_RHEL_6_RPMs_i386_6Server, )
2012-11-12 17:27:32,840 32627:140649636529920: pulp.server.api.repo:ERROR: repo:2192 Unable to find package id for filename=zsh-4.3.10-4.1.el6.i686.rpm, checksum=b1f313882424f9b6ec83c105b76d7d2739584cde
2012-11-12 17:27:32,882 32627:140649636529920: pulp.server.api.repo:ERROR: repo:2192 Unable to find package id for filename=zsh-4.3.10-5.el6.i686.rpm, checksum=a083b24a540f0911da61f453a7a260dc1c5404ea
2012-11-12 17:27:32,882 32627:140649636529920: pulp.server.api.repo:INFO: repo:2208 Translated 2 filename,checksums in 0.11106801033 seconds
2012-11-12 17:27:35,557 32627:140649615550208: pulp.server.api.repo:INFO: repo:2291 Spawning repo metadata generation for repo [redhat-Dev-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_RPMs_i386_6Server] with path [/var/lib/pulp//repos/redhat/Dev/content/dist/rhel/server/6/6Server/i386/os]
2012-11-12 17:27:35,558 32627:140649615550208: pulp.server.util:INFO: util:507 metadata found; taking backup.
2012-11-12 17:27:38,042 32627:140649615550208: pulp.server.util:INFO: util:467 Checking what metadata types are available: ['group', 'filelists', 'updateinfo', 'group_gz', 'primary', 'primary_db', 'other_db', 'other', 'filelists_db', 'productid']
2012-11-12 17:27:38,073 32627:140649615550208: pulp.server.util:INFO: util:489 started repo metadata update: ['createrepo', '--database', '--checksum', 'sha', '-g', '/var/lib/pulp//repos/redhat/Dev/content/dist/rhel/server/6/6Server/i386/os/repodata/comps.xml', '--update', '/var/lib/pulp//repos/redhat/Dev/content/dist/rhel/server/6/6Server/i386/os']
Comment 7 Kedar Bidarkar 2012-11-12 07:09:08 EST
The build used to check the above issue was 2012-11-08.1/  

[root@xyxy ~]# rpm -qav | grep -i katello 
katello-glue-pulp-1.1.12-21.el6cf.noarch
katello-1.1.12-21.el6cf.noarch
katello-cli-common-1.1.8-12.el6cf.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-certs-tools-1.1.8-1.el6cf.noarch
katello-configure-1.1.9-12.el6cf.noarch
katello-all-1.1.12-21.el6cf.noarch
katello-cli-1.1.8-12.el6cf.noarch
katello-common-1.1.12-21.el6cf.noarch
katello-selinux-1.1.1-2.el6cf.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.1.12-21.el6cf.noarch
Comment 10 Mike McCune 2014-03-18 13:38:42 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.