Bug 853478 - SELinux is preventing /usr/sbin/tmpwatch from 'setattr' accesses on the directory H.
SELinux is preventing /usr/sbin/tmpwatch from 'setattr' accesses on the direc...
Status: CLOSED DUPLICATE of bug 853477
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5637becddfb9175df730fecc5b6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 12:44 EDT by Horst H. von Brand
Modified: 2012-09-03 04:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-03 04:15:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2012-08-31 12:44:00 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.9-1.fc16.x86_64
time:           Fri 31 Aug 2012 12:43:41 PM CLT

description:
:SELinux is preventing /usr/sbin/tmpwatch from 'setattr' accesses on the directory H.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that tmpwatch should be allowed setattr access on the H directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep tmpwatch /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tmpreaper_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:dosfs_t:s0
:Target Objects                H [ dir ]
:Source                        tmpwatch
:Source Path                   /usr/sbin/tmpwatch
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           tmpwatch-2.10.3-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-91.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.9-1.fc16.x86_64 #1
:                              SMP Wed Aug 15 20:45:23 UTC 2012 x86_64 x86_64
:Alert Count                   159
:First Seen                    Tue 28 Aug 2012 09:17:34 AM CLT
:Last Seen                     Fri 31 Aug 2012 11:34:44 AM CLT
:Local ID                      fe70f4b0-2a22-4204-814f-6f07af137c33
:
:Raw Audit Messages
:type=AVC msg=audit(1346427284.473:368): avc:  denied  { setattr } for  pid=29686 comm="tmpwatch" name="48" dev="dm-5" ino=175 scontext=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dosfs_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1346427284.473:368): arch=x86_64 syscall=utime success=no exit=EACCES a0=4045eb a1=7fff9d97c2e0 a2=101 a3=0 items=0 ppid=29683 pid=29686 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=3 comm=tmpwatch exe=/usr/sbin/tmpwatch subj=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 key=(null)
:
:Hash: tmpwatch,tmpreaper_t,dosfs_t,dir,setattr
:
:audit2allow
:
:#============= tmpreaper_t ==============
:allow tmpreaper_t dosfs_t:dir setattr;
:
:audit2allow -R
:
:#============= tmpreaper_t ==============
:allow tmpreaper_t dosfs_t:dir setattr;
:
Comment 1 Miroslav Grepl 2012-09-03 04:15:51 EDT

*** This bug has been marked as a duplicate of bug 853477 ***

Note You need to log in before you can comment on or make changes to this bug.