Bug 853571 - man page for rhsmcertd indicates SECONDS and should be MINUTES
man page for rhsmcertd indicates SECONDS and should be MINUTES
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Deon Ballard
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-31 18:25 EDT by John Sefler
Modified: 2013-01-07 23:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:02:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-08-31 18:25:08 EDT
Description of problem:
According to the tools, the interval units for certFrequency and healFrequency should be minutes with the defaults shown below...

[root@jsefler-59client ~]# rhsmcertd --help | grep -i interval
  -c, --cert-interval=MINUTES     Interval to run cert check (in minutes)
  -i, --heal-interval=MINUTES     Interval to run healing (in minutes)

[root@jsefler-59client ~]# grep -i frequency /etc/rhsm/rhsm.conf
# Frequency of certificate refresh (in minutes):
certFrequency = 240
# Frequency of autoheal check (1440 min = 1 day):
healFrequency = 1440


[root@jsefler-59client ~]# man -P cat rhsmcertd | grep -i second
       rhsmcertd [--cert-interval=SECONDS]  [--heal-interval=SECONDS]  [--now]
              cates.  This  value is in seconds. The default is 14400, or four
              scriptions.  This  value is in seconds. The default is 86400, or

^^^^ THE MAN PAGE FOR rhsmcertd IS SHOWING UNITS OF SECONDS WITH DEFAULT VALUES THAT ARE WRONG.



Version-Release number of selected component (if applicable):
[root@jsefler-59client ~]# rpm -q subscription-manager
subscription-manager-1.0.17-1.el5
[root@jsefler-59client ~]# man -P cat rhsmcertd | grep version
       General  Public  License,  version 2 (GPLv2). A copy of this license is
version 1.1                      July 18, 2012                    rhsmcertd(8)
Comment 1 RHEL Product and Program Management 2012-08-31 18:28:05 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Deon Ballard 2012-09-06 14:19:30 EDT
Stealing this bug.
Comment 3 Deon Ballard 2012-09-06 15:00:49 EDT
Committed to master:
360a83b4cc47e0557cffd3e967b71b07ce0fa8a0
Comment 6 John Sefler 2012-09-14 17:50:07 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.18-1.el5
[root@jsefler-rhel59 ~]# man -P cat rhsmcertd | grep version
       General Public License, version 2 (GPLv2). A copy of  this  license  is
version 1.3                    September 6, 2012                  rhsmcertd(8)


[root@jsefler-rhel59 ~]# man rhsmcertd

EXCERPTS FROM THE FIXED MAN PAGE...

       rhsmcertd   [--cert-interval=MINUTES]    [--heal-interval=MINUTES]
       [--now] [--debug] [--help]

       -c, --cert-interval=MINUTES
              Resets  the interval for checking for new subscription cer-
              tificates. This value is in minutes. The default is 240, or
              four  hours.  This  interval  is in effect until the daemon
              restarts, and then the values  in  the  /etc/rhsm/rhsm.conf
              file are used (unless the argument is passed again).


       -i, --heal-interval=MINUTES
              Resets  the interval for checking for and replacing expired
              subscriptions. This value is in  minutes.  The  default  is
              1440,  or  24  hours.  This interval is in effect until the
              daemon   restarts,   and   then   the   values    in    the
              /etc/rhsm/rhsm.conf  file  are used (unless the argument is
              passed again).

^^^ VERIFIED: The interval units and default values have been correctly documented.
Comment 8 errata-xmlrpc 2013-01-07 23:02:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.