Bug 853577 - [abrt] mirall-1.0.5-4.fc17: XFreeColormap: Process /usr/bin/mirall was killed by signal 11 (SIGSEGV)
[abrt] mirall-1.0.5-4.fc17: XFreeColormap: Process /usr/bin/mirall was killed...
Status: CLOSED DUPLICATE of bug 852146
Product: Fedora
Classification: Fedora
Component: mirall (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joseph Marrero
Fedora Extras Quality Assurance
abrt_hash:063a9c17e69220b653091b5baad...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-31 19:04 EDT by matiaspakua
Modified: 2012-09-15 13:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-15 13:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.00 KB, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: environ (1.65 KB, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: error_log (65.81 KB, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: event_log (2.12 KB, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: limits (1.29 KB, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: backtrace (30.86 KB, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: cgroup (129 bytes, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: smolt_data (3.19 KB, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: maps (42.71 KB, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: dso_list (13.97 KB, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details
File: open_fds (416 bytes, text/plain)
2012-08-31 19:04 EDT, matiaspakua
no flags Details

  None (edit)
Description matiaspakua 2012-08-31 19:04:08 EDT
Version-Release number of selected component:
mirall-1.0.5-4.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        mirall
crash_function: XFreeColormap
kernel:         3.5.2-3.fc17.i686.PAE

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 XFreeColormap at FreeCmap.c
: #1 QSystemTrayIconSys::~QSystemTrayIconSys at util/qsystemtrayicon_x11.cpp
: #3 QSystemTrayIconPrivate::remove_sys at util/qsystemtrayicon_x11.cpp
: #4 QSystemTrayIcon::~QSystemTrayIcon at util/qsystemtrayicon.cpp
: #6 QObjectPrivate::deleteChildren at kernel/qobject.cpp
: #7 QObject::~QObject at kernel/qobject.cpp
: #8 QCoreApplication::~QCoreApplication at kernel/qcoreapplication.cpp
: #9 QApplication::~QApplication at kernel/qapplication.cpp
: #10 ~QtSingleApplication at /usr/src/debug/mirall-1.0.5/src/3rdparty/qtsingleapplication/qtsingleapplication.h
: #11 Mirall::Application::~Application at /usr/src/debug/mirall-1.0.5/src/mirall/application.cpp
Comment 1 matiaspakua 2012-08-31 19:04:11 EDT
Created attachment 608734 [details]
File: core_backtrace
Comment 2 matiaspakua 2012-08-31 19:04:13 EDT
Created attachment 608735 [details]
File: environ
Comment 3 matiaspakua 2012-08-31 19:04:16 EDT
Created attachment 608736 [details]
File: error_log
Comment 4 matiaspakua 2012-08-31 19:04:18 EDT
Created attachment 608737 [details]
File: event_log
Comment 5 matiaspakua 2012-08-31 19:04:22 EDT
Created attachment 608738 [details]
File: limits
Comment 6 matiaspakua 2012-08-31 19:04:25 EDT
Created attachment 608739 [details]
File: backtrace
Comment 7 matiaspakua 2012-08-31 19:04:27 EDT
Created attachment 608740 [details]
File: cgroup
Comment 8 matiaspakua 2012-08-31 19:04:29 EDT
Created attachment 608741 [details]
File: smolt_data
Comment 9 matiaspakua 2012-08-31 19:04:32 EDT
Created attachment 608742 [details]
File: maps
Comment 10 matiaspakua 2012-08-31 19:04:35 EDT
Created attachment 608743 [details]
File: dso_list
Comment 11 matiaspakua 2012-08-31 19:04:37 EDT
Created attachment 608744 [details]
File: open_fds
Comment 12 Joseph Marrero 2012-09-03 02:13:57 EDT
Please test it seems to solve the problem on my machine (x86_64) and virtual Box i686 box

http://koji.fedoraproject.org/koji/buildinfo?buildID=351736

if work out please leave positive feedback here: 
https://admin.fedoraproject.org/updates/mirall-1.0.5-5.fc17
Comment 13 Joseph Marrero 2012-09-03 19:40:14 EDT
The updates are in the updates-testing repo.

Please test the latest update on owncloud-client and/or mirall
Use the following commands depending on which sync client are you using.

If you are using owncloud-client:
yum --enablerepo=updates-testing install mirall-common owncloud-client


If you are using mirall:
yum --enablerepo=updates-testing install mirall-common mirall

-- 
Joseph
Comment 14 Joseph Marrero 2012-09-15 13:36:11 EDT

*** This bug has been marked as a duplicate of bug 852146 ***

Note You need to log in before you can comment on or make changes to this bug.