Bug 853628 - PartitioningError: you have not created a bootloader stage1 target device
PartitioningError: you have not created a bootloader stage1 target device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:85a3b22facc606c56d8f13446ba...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-01 10:24 EDT by A.J. Werkman
Modified: 2012-11-22 20:25 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 20:25:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (687 bytes, text/plain)
2012-09-01 10:24 EDT, A.J. Werkman
no flags Details
File: anaconda-tb (414.27 KB, text/plain)
2012-09-01 10:24 EDT, A.J. Werkman
no flags Details
File: environ (756 bytes, text/plain)
2012-09-01 10:24 EDT, A.J. Werkman
no flags Details
File: type (9 bytes, text/plain)
2012-09-01 10:24 EDT, A.J. Werkman
no flags Details
File: storage.log (188.79 KB, text/plain)
2012-09-01 10:24 EDT, A.J. Werkman
no flags Details
File: version (12 bytes, text/plain)
2012-09-01 10:24 EDT, A.J. Werkman
no flags Details
File: program.log (67.32 KB, text/plain)
2012-09-01 10:24 EDT, A.J. Werkman
no flags Details
File: product (6 bytes, text/plain)
2012-09-01 10:25 EDT, A.J. Werkman
no flags Details
File: syslog (116.03 KB, text/plain)
2012-09-01 10:25 EDT, A.J. Werkman
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-09-01 10:25 EDT, A.J. Werkman
no flags Details
File: anaconda.log (11.12 KB, text/plain)
2012-09-01 10:25 EDT, A.J. Werkman
no flags Details
File: release (24 bytes, text/plain)
2012-09-01 10:25 EDT, A.J. Werkman
no flags Details
File: description (599 bytes, text/plain)
2012-09-01 10:25 EDT, A.J. Werkman
no flags Details
anaconda-tb-* traceback and debuginfo (274.45 KB, text/plain)
2012-09-13 16:02 EDT, John Reiser
no flags Details
storage.log (109.54 KB, text/plain)
2012-09-13 16:03 EDT, John Reiser
no flags Details
storage.state (20.00 KB, text/plain)
2012-09-13 16:04 EDT, John Reiser
no flags Details
syslog (/var/log/messages) (101.74 KB, text/plain)
2012-09-13 16:04 EDT, John Reiser
no flags Details

  None (edit)
Description A.J. Werkman 2012-09-01 10:24:36 EDT
Description of problem:


Version-Release number of selected component:
anaconda-18.6.4

Additional info:
libreport version: 2.0.12
cmdline:        BOOT_IMAGE=/images/pxeboot/vmlinuz nomodeset root=live:LABEL=CFL_17
kernel:         3.6.0-0.rc2.git2.1.fc18.i686
Comment 1 A.J. Werkman 2012-09-01 10:24:39 EDT
Created attachment 608846 [details]
File: ifcfg.log
Comment 2 A.J. Werkman 2012-09-01 10:24:45 EDT
Created attachment 608847 [details]
File: anaconda-tb
Comment 3 A.J. Werkman 2012-09-01 10:24:48 EDT
Created attachment 608848 [details]
File: environ
Comment 4 A.J. Werkman 2012-09-01 10:24:50 EDT
Created attachment 608849 [details]
File: type
Comment 5 A.J. Werkman 2012-09-01 10:24:53 EDT
Created attachment 608850 [details]
File: storage.log
Comment 6 A.J. Werkman 2012-09-01 10:24:55 EDT
Created attachment 608851 [details]
File: version
Comment 7 A.J. Werkman 2012-09-01 10:24:57 EDT
Created attachment 608852 [details]
File: program.log
Comment 8 A.J. Werkman 2012-09-01 10:25:00 EDT
Created attachment 608853 [details]
File: product
Comment 9 A.J. Werkman 2012-09-01 10:25:03 EDT
Created attachment 608854 [details]
File: syslog
Comment 10 A.J. Werkman 2012-09-01 10:25:05 EDT
Created attachment 608855 [details]
File: hashmarkername
Comment 11 A.J. Werkman 2012-09-01 10:25:08 EDT
Created attachment 608856 [details]
File: anaconda.log
Comment 12 A.J. Werkman 2012-09-01 10:25:11 EDT
Created attachment 608857 [details]
File: release
Comment 13 A.J. Werkman 2012-09-01 10:25:13 EDT
Created attachment 608858 [details]
File: description
Comment 14 Chris Lumens 2012-09-01 11:27:18 EDT
What steps did you take that led to this situation?
Comment 15 A.J. Werkman 2012-09-01 12:35:01 EDT
Steps are:
1. Have vmlinuz, initrd.img and squashfs.img on a USB.
2. Boot from this USB
3. In the central screen chose http-installation from a server in my network that has the tree for F18a TC5.
4. Chose minimal install and added base.
5. Came to the partitioning screen and selected drive. On this drive I have a disk layout from a previous F17. But as far as I recall the F17 was not on the system anymore. Layout: Boot partition Ext4 1024M, Root partition Ext4 30000M, Swap partition 4096M.
6. I do not exactly what I clicked and in which order, but I tried to create a partitioning scheme where anaconda was satified with. Then BOOM  exception, that I send to bugzilla.

With TC5 I have now tried several strategies to create a partitioning scheme to install on, but without exception I end up in an exception.
Comment 16 A.J. Werkman 2012-09-01 12:45:44 EDT
Can reproduce this one now.

I ereased all partitions with the windows installtion program and installed a small win-partition.
Then followed the steps from comment #15 clicked the destination icon, selected the only disc show in the menu, did not check the review field and selected "continue". Exception then comes after 2 or 3 seconds.
Comment 17 John Reiser 2012-09-13 15:06:31 EDT
The same symptom is reproducible in anaconda-18.6.7 booted from DVD on a machine with exactly one harddrive that has a GPT disk label and no partitions.  Ask to review layout, "Click here to make all mount points now" then [Continue].
Comment 18 David Lehman 2012-09-13 15:44:21 EDT
(In reply to comment #15)
> Steps are:
> 1. Have vmlinuz, initrd.img and squashfs.img on a USB.
> 2. Boot from this USB
> 3. In the central screen chose http-installation from a server in my network
> that has the tree for F18a TC5.
> 4. Chose minimal install and added base.
> 5. Came to the partitioning screen and selected drive. On this drive I have
> a disk layout from a previous F17. But as far as I recall the F17 was not on
> the system anymore. Layout: Boot partition Ext4 1024M, Root partition Ext4
> 30000M, Swap partition 4096M.

This sounds like a known bug that will be fixed in the first beta trees. Removable devices containing install media are excluded from the initial disk selection, but not from custom partitioning. They should be excluded from both, especially since all selected disks are treated as fair game for partition allocation.

There may be other issues related to GPT disklabels on BIOS systems. We'll have to wait and see.
Comment 19 David Lehman 2012-09-13 15:45:12 EDT
(In reply to comment #17)
> The same symptom is reproducible in anaconda-18.6.7 booted from DVD on a
> machine with exactly one harddrive that has a GPT disk label and no
> partitions.  Ask to review layout, "Click here to make all mount points now"
> then [Continue].

Please attach your logs.
Comment 20 John Reiser 2012-09-13 16:02:50 EDT
Created attachment 612612 [details]
anaconda-tb-* traceback and debuginfo

Reproduced with anaconda-18.6.8: one drive [brand new, never used], GPT, no partitions.
Comment 21 John Reiser 2012-09-13 16:03:32 EDT
Created attachment 612614 [details]
storage.log

One drive [brand new, never used], GPT, no partitions.
Comment 22 John Reiser 2012-09-13 16:04:05 EDT
Created attachment 612615 [details]
storage.state
Comment 23 John Reiser 2012-09-13 16:04:33 EDT
Created attachment 612616 [details]
syslog (/var/log/messages)
Comment 24 David Lehman 2012-09-13 16:34:10 EDT
Thanks. So there's also a bug about whether to add a BIOS boot partition during automatic partitioning. I have a patch, so it should be resolved in the earliest beta trees as well.
Comment 25 Fedora Update System 2012-09-26 19:01:58 EDT
anaconda-18.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.10-1.fc18
Comment 26 Fedora Update System 2012-09-27 20:19:41 EDT
Package anaconda-18.10-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.10-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14933/anaconda-18.10-1.fc18
then log in and leave karma (feedback).
Comment 27 Fedora Update System 2012-10-02 10:13:15 EDT
anaconda-18.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.11-1.fc18
Comment 28 Fedora Update System 2012-10-03 20:58:09 EDT
anaconda-18.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.12-1.fc18
Comment 29 Adam Williamson 2012-11-22 20:25:39 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(tested a gpt autopart install of Beta RC1 by passing 'gpt' on cmdline, worked fine, created a BIOS boot part.)

Note You need to log in before you can comment on or make changes to this bug.