Bug 853702 - Ovirt SDK: Can't add correlation id to update and delete template nic
Ovirt SDK: Can't add correlation id to update and delete template nic
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ori Liel
Yaniv Kaul
network, infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-02 05:09 EDT by Avi Tal
Modified: 2016-04-22 00:59 EDT (History)
10 users (show)

See Also:
Fixed In Version: si18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Tal 2012-09-02 05:09:58 EDT
Got the following ERROR after adding correlation_id to update or remove template nic:

TypeError: update() got an unexpected keyword argument 'correlation_id'
or
TypeError: delete() got an unexpected keyword argument 'correlation_id'
Comment 1 Michael Pasternak 2012-09-02 05:16:44 EDT
Ori, please go over all relevant CI items in RSDL and make sure
they are really have correlation_id header according to metadata 
you have added.
Comment 2 Ori Liel 2012-09-02 09:42:12 EDT
Looks like more than just correlation-id probelm, the sigantures: 

- name: /api/templates/{template:id}/nics/{nic:id}|rel=delete
- name: /api/templates/{template:id}/nics/{nic:id}|rel=update

were completely missing from .yaml metadata file. 

patch posted upstream, http://gerrit.ovirt.org/#/c/7676/
Comment 3 Ori Liel 2012-09-05 07:35:51 EDT
patch posted upstream (http://gerrit.ovirt.org/#/c/7676) and merged: 

  commit 9279ee30b42cab7202dc7a43326fb9c1367f4cd2

patch posted downstream: https://gerrit.eng.lab.tlv.redhat.com/#/c/1848/   (awaiting approval)
Comment 4 Ori Liel 2012-09-06 09:23:05 EDT
merged downstream, 

  commit 5c7cc9e46e98d1679e213be359d2eb872e564078
Comment 5 Avi Tal 2012-09-19 05:09:07 EDT
Verify on SI18 - PASS

Note You need to log in before you can comment on or make changes to this bug.