Bug 853704 - ovirt-engine-backend [TEXT]: same action in progress error when putting spm and master domain in maintenance at the same time
ovirt-engine-backend [TEXT]: same action in progress error when putting spm a...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Oved Ourfali
Leonid Natapov
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-02 05:26 EDT by Dafna Ron
Modified: 2016-02-10 14:36 EST (History)
12 users (show)

See Also:
Fixed In Version: si19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:03:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (27.79 KB, application/x-xz)
2012-09-02 05:26 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-09-02 05:26:36 EDT
Created attachment 609038 [details]
log

Description of problem:

when we try to put SPM host and master SD in maintenance at the same time we are getting CanDoAction: "Same Action in Progress" from locking mechanism. 

2012-09-02 12:15:43,521 WARN  [org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand] (ajp-/127.0.0.1:8009-4) CanDoAction of action DeactivateStorageDomain failed. R
easons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__DEACTIVATE,ACTION_TYPE_FAILED_OBJECT_LOCKED


Version-Release number of selected component (if applicable):

si16

How reproducible:

100%

Steps to Reproduce:
1. in two hosts cluster with multiple domains -> put spm + master domain in maintenance at the same time. 
2.
3.
  
Actual results:

we are failing on lock with CanDoAction: 
2012-09-02 12:15:43,521 WARN  [org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand] (ajp-/127.0.0.1:8009-4) CanDoAction of action DeactivateStorageDomain failed. R
easons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__DEACTIVATE,ACTION_TYPE_FAILED_OBJECT_LOCKED


Expected results:

since spm recontending and master domain reconstruct are not the same actions we should have a different canDoAction. 

Additional info:backend log
Comment 1 Ayal Baron 2012-09-02 07:16:29 EDT
(In reply to comment #0)
> Created attachment 609038 [details]
> log
> 
> Description of problem:
> 
> when we try to put SPM host and master SD in maintenance at the same time we
> are getting CanDoAction: "Same Action in Progress" from locking mechanism. 
> 
> 2012-09-02 12:15:43,521 WARN 
> [org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand]
> (ajp-/127.0.0.1:8009-4) CanDoAction of action DeactivateStorageDomain
> failed. R
> easons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__DEACTIVATE,
> ACTION_TYPE_FAILED_OBJECT_LOCKED
> 
> 
> Version-Release number of selected component (if applicable):
> 
> si16
> 
> How reproducible:
> 
> 100%
> 
> Steps to Reproduce:
> 1. in two hosts cluster with multiple domains -> put spm + master domain in
> maintenance at the same time. 
> 2.
> 3.
>   
> Actual results:
> 
> we are failing on lock with CanDoAction: 
> 2012-09-02 12:15:43,521 WARN 
> [org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand]
> (ajp-/127.0.0.1:8009-4) CanDoAction of action DeactivateStorageDomain
> failed. R
> easons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__DEACTIVATE,
> ACTION_TYPE_FAILED_OBJECT_LOCKED
> 
> 
> Expected results:
> 
> since spm recontending and master domain reconstruct are not the same
> actions we should have a different canDoAction. 
> 
> Additional info:backend log

This is not reconstruct, but in any event the error is wrong in general.

This is in CommandBase.java:

log.infoFormat("Failed to Acquire Lock to object {0}", lock);                    addCanDoActionMessage(VdcBllMessages.ACTION_TYPE_FAILED_OBJECT_LOCKED);
Comment 2 Oved Ourfali 2012-09-04 01:59:28 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > Created attachment 609038 [details]
> > log
> > 
> > Description of problem:
> > 
> > when we try to put SPM host and master SD in maintenance at the same time we
> > are getting CanDoAction: "Same Action in Progress" from locking mechanism. 
> > 
> > 2012-09-02 12:15:43,521 WARN 
> > [org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand]
> > (ajp-/127.0.0.1:8009-4) CanDoAction of action DeactivateStorageDomain
> > failed. R
> > easons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__DEACTIVATE,
> > ACTION_TYPE_FAILED_OBJECT_LOCKED
> > 
> > 
> > Version-Release number of selected component (if applicable):
> > 
> > si16
> > 
> > How reproducible:
> > 
> > 100%
> > 
> > Steps to Reproduce:
> > 1. in two hosts cluster with multiple domains -> put spm + master domain in
> > maintenance at the same time. 
> > 2.
> > 3.
> >   
> > Actual results:
> > 
> > we are failing on lock with CanDoAction: 
> > 2012-09-02 12:15:43,521 WARN 
> > [org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand]
> > (ajp-/127.0.0.1:8009-4) CanDoAction of action DeactivateStorageDomain
> > failed. R
> > easons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__DEACTIVATE,
> > ACTION_TYPE_FAILED_OBJECT_LOCKED
> > 
> > 
> > Expected results:
> > 
> > since spm recontending and master domain reconstruct are not the same
> > actions we should have a different canDoAction. 
> > 
> > Additional info:backend log
> 
> This is not reconstruct, but in any event the error is wrong in general.
> 
> This is in CommandBase.java:
> 
> log.infoFormat("Failed to Acquire Lock to object {0}", lock);               
> addCanDoActionMessage(VdcBllMessages.ACTION_TYPE_FAILED_OBJECT_LOCKED);

ACTION_TYPE_FAILED_OBJECT_LOCKED is mapped to the following message:

Cannot ${action} ${type}. Same action in progress.

Maybe we should change it to:

Cannot ${action} ${type}. Related operation is currently on progress. Please try again later.
Other suggestions are welcome.

Ayal - any thoghts about that?
Comment 5 Oved Ourfali 2012-09-24 10:49:26 EDT
Posted patch:
http://gerrit.ovirt.org/8166
Comment 6 Oved Ourfali 2012-09-24 10:55:58 EDT
Commit: be6f6fcc8a5df1d3c6ab1f07b91dfef6bc448bcc

http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=be6f6fcc8a5df1d3c6ab1f07b91dfef6bc448bcc
Comment 8 Leonid Natapov 2012-10-02 09:05:36 EDT
si19. fixed. getting the following message:

"Error while executing action: Cannot maintenance Host. Related operation is currently in progress. Please try again later."

Note You need to log in before you can comment on or make changes to this bug.