Bug 853715 - rhevm-iso-uploader fail on missing parameters for SSL connection
rhevm-iso-uploader fail on missing parameters for SSL connection
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Keith Robertson
Ilanit Stein
integration
: Regression, TestBlocker
: 853720 (view as bug list)
Depends On:
Blocks: 847833 854703 854721
  Show dependency treegraph
 
Reported: 2012-09-02 07:17 EDT by Ilanit Stein
Modified: 2016-07-03 21:35 EDT (History)
13 users (show)

See Also:
Fixed In Version: rhevm-iso-uploader-3.1.0-4.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 854703 854721 (view as bug list)
Environment:
Last Closed: 2012-12-04 14:58:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilanit Stein 2012-09-02 07:17:36 EDT
Description of problem:

After clean installation of rhevm SI16, 
"rhevm-iso-uploader -v list" fail
on "key_file, cert_file, ca_file must be specified for SSL connection."

Version-Release number of selected component (if applicable):
SI16

How reproducible:
always

Steps to Reproduce:

Just run rhevm-iso-uploader -v list on rhevm console.
(I used the user admin@internal)  

Expected results:

The command should work and give iso list, but instead it fails on some missing parameters. If indeed there are missing parameters, in order to activate the command, it should be stated in the coomand help, but they are not.

logs:

no logs here, as command fail to run.
Comment 3 Oded Ramraz 2012-09-02 07:48:33 EDT
*** Bug 853720 has been marked as a duplicate of this bug. ***
Comment 9 Keith Robertson 2012-09-05 13:40:54 EDT
http://gerrit.ovirt.org/7774
Comment 11 Ohad Basan 2012-09-12 15:12:29 EDT
Failed integration testing
Comment 12 Oded Ramraz 2012-09-14 07:33:22 EDT
[root@aqua-rhel ~]# rhevm-iso-uploader  list
Please provide the REST API password for the admin@internal RHEV-M user (CTRL+D to abort): 
ISO Storage Domain Name   | Datacenter                | ISO Domain Status
ISO                       | Default                   | active

Verified si18

Note You need to log in before you can comment on or make changes to this bug.