Bug 853719 - [abrt] util-linux-2.21.2-2.fc17: probe_ntfs: Process /usr/sbin/wipefs was killed by signal 11 (SIGSEGV)
[abrt] util-linux-2.21.2-2.fc17: probe_ntfs: Process /usr/sbin/wipefs was kil...
Status: CLOSED DUPLICATE of bug 851230
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
abrt_hash:5b6b4896ea26f87602a0b79410c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-02 07:35 EDT by D. Charles Pyle
Modified: 2012-09-06 06:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 06:42:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (271 bytes, text/plain)
2012-09-02 07:35 EDT, D. Charles Pyle
no flags Details
File: environ (163 bytes, text/plain)
2012-09-02 07:36 EDT, D. Charles Pyle
no flags Details
File: event_log (689 bytes, text/plain)
2012-09-02 07:36 EDT, D. Charles Pyle
no flags Details
File: backtrace (10.26 KB, text/plain)
2012-09-02 07:36 EDT, D. Charles Pyle
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-02 07:36 EDT, D. Charles Pyle
no flags Details
File: cgroup (160 bytes, text/plain)
2012-09-02 07:36 EDT, D. Charles Pyle
no flags Details
File: maps (2.32 KB, text/plain)
2012-09-02 07:36 EDT, D. Charles Pyle
no flags Details
File: dso_list (495 bytes, text/plain)
2012-09-02 07:36 EDT, D. Charles Pyle
no flags Details
File: var_log_messages (336 bytes, text/plain)
2012-09-02 07:36 EDT, D. Charles Pyle
no flags Details
File: open_fds (141 bytes, text/plain)
2012-09-02 07:36 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-09-02 07:35:56 EDT
Description of problem:
I am not quite sure what is causing this problem but it might have something to do with testing I am doing with a new version of blkid and libblkid I am testing that fixes a problem with identifying and reading (at boot time) NTFS partitions set up with Boot Camp and allows the device to be shown in the Devices sidebar in Nautilus.

This is my dmesg output in a Terminal Window:

$ dmesg | grep udev
[    1.803992] udevd[115]: starting version 182
[    2.652225] udevd[219]: segfault at 7f3547d5331c ip 00007f35b3c869de sp 00007fff020296e0 error 4 in libblkid.so.1.1.0[7f35b3c72000+24000]
[    7.652616] udevd[392]: starting version 182

I do not see this error frequently yet but it may be related. It still is in testing but is important to know for further development.


Version-Release number of selected component:
util-linux-2.21.2-2.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        wipefs -a /dev/sda3
crash_function: probe_ntfs
kernel:         3.5.2-3.fc17.x86_64

truncated backtrace:
:Thread no. 1 (4 frames)
: #0 probe_ntfs at ntfs.c
: #1 superblocks_probe at superblocks.c
: #2 blkid_do_probe at probe.c
: #3 do_wipe at wipefs.c
Comment 1 D. Charles Pyle 2012-09-02 07:35:59 EDT
Created attachment 609060 [details]
File: core_backtrace
Comment 2 D. Charles Pyle 2012-09-02 07:36:01 EDT
Created attachment 609061 [details]
File: environ
Comment 3 D. Charles Pyle 2012-09-02 07:36:02 EDT
Created attachment 609062 [details]
File: event_log
Comment 4 D. Charles Pyle 2012-09-02 07:36:04 EDT
Created attachment 609063 [details]
File: backtrace
Comment 5 D. Charles Pyle 2012-09-02 07:36:05 EDT
Created attachment 609064 [details]
File: limits
Comment 6 D. Charles Pyle 2012-09-02 07:36:07 EDT
Created attachment 609065 [details]
File: cgroup
Comment 7 D. Charles Pyle 2012-09-02 07:36:08 EDT
Created attachment 609066 [details]
File: maps
Comment 8 D. Charles Pyle 2012-09-02 07:36:10 EDT
Created attachment 609067 [details]
File: dso_list
Comment 9 D. Charles Pyle 2012-09-02 07:36:11 EDT
Created attachment 609068 [details]
File: var_log_messages
Comment 10 D. Charles Pyle 2012-09-02 07:36:13 EDT
Created attachment 609069 [details]
File: open_fds
Comment 11 D. Charles Pyle 2012-09-03 13:44:09 EDT
After some updates, including a newer kernel with the newer compiled files copied to their proper locations, I am seeing the following:

$ dmesg | grep udev
[    1.818604] udevd[115]: starting version 182
[    7.610723] udevd[420]: starting version 182

Looks like the crashing might be gone. Testing continues...
Comment 12 Karel Zak 2012-09-06 06:42:38 EDT

*** This bug has been marked as a duplicate of bug 851230 ***

Note You need to log in before you can comment on or make changes to this bug.