Bug 853720 - ovirt-engine-iso-uploader : Cannot run rhevm-iso-uploader due to missing certificates
ovirt-engine-iso-uploader : Cannot run rhevm-iso-uploader due to missing cert...
Status: CLOSED DUPLICATE of bug 853715
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Barak
Ilanit Stein
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-02 07:45 EDT by Oded Ramraz
Modified: 2012-09-02 07:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-02 07:48:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Ramraz 2012-09-02 07:45:35 EDT
Description of problem:

When I'm trying to use rhevm-iso-uploader I'm getting an error due to missing certificates ( see Additional Information ) 
After updating the connection settings in the code and adding insecure=True the problem disappear . 

self.api = API(url=url,
                           username=self.configuration.get("user"),
                           password=self.configuration.get("passwd"),
                     insecure=True)


This problem will probably affect other utilities which are using SDK . 


Version-Release number of selected component (if applicable):




How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[root@aqua-rhel ~]# rhevm-iso-uploader list
Please provide the REST API password for the admin@internal RHEV-M user (CTRL+D to abort): 
ERROR: [ERROR]::key_file, cert_file, ca_file must be specified for SSL connection.
INFO: Use the -h option to see usage.
Comment 1 Oded Ramraz 2012-09-02 07:48:33 EDT

*** This bug has been marked as a duplicate of bug 853715 ***

Note You need to log in before you can comment on or make changes to this bug.