Bug 853736 - AVC messages when mounting lvm lv on /home/hans/Music
AVC messages when mounting lvm lv on /home/hans/Music
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-02 10:11 EDT by Hans de Goede
Modified: 2012-09-12 19:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 19:51:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2012-09-02 10:11:31 EDT
Hi,

I've just upgraded to F-18, and I've noticed the following messages in dmesg:

[   12.912216] EXT4-fs (dm-2): mounted filesystem with ordered data mode. Opts: (null)
[   12.912230] SELinux: initialized (dev dm-2, type ext4), uses xattr
[   12.912454] type=1400 audit(1346591520.318:5): avc:  denied  { write } for  pid=547 comm="mount" name="/" dev="dm-2" ino=2 scontext=system_u:system_r:mount_t:s0 tcontext=unconfined_u:object_r:audio_home_t:s0 tclass=dir

As explained in $summary /dev/dm-2 is a lvm logical volume and it is getting mounted on /home/hans/Music, despite the AVC the mount seems to work fine.

Thanks & Regards,

Hans
Comment 1 Miroslav Grepl 2012-09-03 05:15:14 EDT
It looks like an upgrade issue. Did it happen only once?
Comment 2 Hans de Goede 2012-09-03 07:53:19 EDT
(In reply to comment #1)
> It looks like an upgrade issue. Did it happen only once?

No, dmesg | grep avc for todays fresh boot gives:

[   13.858296] type=1400 audit(1346655085.262:5): avc:  denied  { write } for  pid=579 comm="mount" name="/" dev="dm-2" ino=2 scontext=system_u:system_r:mount_t:s0 tcontext=unconfined_u:object_r:audio_home_t:s0 tclass=dir
[   13.858365] type=1400 audit(1346655085.262:6): avc:  denied  { setattr } for  pid=579 comm="mount" name="/" dev="dm-2" ino=2 scontext=system_u:system_r:mount_t:s0 tcontext=unconfined_u:object_r:audio_home_t:s0 tclass=dir

Not sure why I did not see the setattr the other day, may be related to a new systemd version.
Comment 3 Daniel Walsh 2012-09-06 23:33:47 EDT
Fixed in selinux-policy-3.11.1-16.fc18.noarch


Added these rules to mount_anyfile boolean.
Comment 4 Fedora Update System 2012-09-07 09:25:49 EDT
selinux-policy-3.11.1-16.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-16.fc18
Comment 5 Fedora Update System 2012-09-07 15:37:52 EDT
Package selinux-policy-3.11.1-16.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-16.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13554/selinux-policy-3.11.1-16.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-09-12 08:32:49 EDT
selinux-policy-3.11.1-18.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-13554/selinux-policy-3.11.1-18.fc18
Comment 7 Fedora Update System 2012-09-12 15:13:03 EDT
Package selinux-policy-3.11.1-18.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-18.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13554/selinux-policy-3.11.1-18.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-09-12 19:51:54 EDT
selinux-policy-3.11.1-18.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.