Bug 85395 - modprobe: Can't locate module char-major-188
modprobe: Can't locate module char-major-188
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: modutils (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
: 128172 (view as bug list)
Depends On:
Blocks: 123574
  Show dependency treegraph
 
Reported: 2003-02-28 20:37 EST by David White
Modified: 2014-03-16 22:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-10 16:47:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David White 2003-02-28 20:37:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
message repeated 15x in /var/log/messages

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. No clue where the message is comming from..
2.
3.
    

Additional info:
Comment 1 Bill Nottingham 2003-03-03 16:12:32 EST
USB serial port. Are you using a PDA of some sort?
Comment 2 David White 2003-03-03 22:12:53 EST
No PDA...  The only USB device is a Visioneer 5300 scanner.  I don't recall 
seeing this message on the previous Phoebe beta.
Comment 3 Bill Nottingham 2003-03-03 22:55:25 EST
What sort of messages are in /var/log/messages around these messages?
Comment 4 David White 2003-03-04 22:31:51 EST
From /var/log/messages:
Mar  4 22:19:49 localhost crond: crond startup succeeded
Mar  4 22:19:51 localhost kernel: parport0: PC-style at 0x378 [PCSPP,TRISTATE,EPP]
Mar  4 22:19:51 localhost kernel: parport0: Printer, HEWLETT-PACKARD DESKJET 960C
Mar  4 22:19:51 localhost kernel: lp0: using parport0 (polling).
Mar  4 22:19:51 localhost kernel: lp0: console ready
Mar  4 22:19:51 localhost modprobe: modprobe: Can't locate module char-major-188
Mar  4 22:19:51 localhost last message repeated 15 times
Mar  4 22:19:51 localhost cups: cupsd startup succeeded
Mar  4 22:19:52 localhost xfs: xfs startup succeeded

Here's the USB stuff from dmesg:
usb-uhci.c: USB UHCI at I/O 0xef80, IRQ 3
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
hub.c: new USB device 00:1f.2-2, assigned address 2
usb.c: USB device 2 (vend/prod 0x4a7/0x221) is not claimed by any active driver.
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,3), internal journal
Adding Swap: 1052248k swap-space (priority -1)
usb.c: registered new driver usbscanner
scanner.c: probe_scanner: Undetected endpoint -- consult
Documentation/usb/scanner.txt.
scanner.c: 0.4.9:USB Scanner Driver

Anything else you need?
Comment 5 Bill Nottingham 2003-05-28 15:43:37 EDT
Tim, does cups ever try to open /dev/ttyUSB*? If so, why? :)
Comment 6 Tim Waugh 2003-05-28 17:38:59 EDT
Yes, the serial backend does when probing for printers.  Is it a problem?
Comment 7 Bill Nottingham 2003-05-28 17:48:19 EDT
Not necessarily, but it explains where the message comes from.
Comment 8 Wayne Schuller 2003-12-07 03:05:57 EST
the messages are very disturbing...

I think this will continue to cause concern amongst users.

even if it is not really a bug, it sounds like a misconfigured kernel
modul or system config or something else bad.
Comment 9 Scott N. Blackman 2003-12-11 02:41:29 EST
I get modprobe: Can't locate module char-major-188 only after I
install ALSA.

And have found that redhat-control-network die about 1 in 4 times,
only after I install AlSA.
Comment 10 Kenneth Heal 2004-02-01 07:28:21 EST
I have a system running RedHat 9 Kernel 2.4.20-28.9 on an i686 Intel
ISP1000 and was seeing these errors too.

I added the following lines to /etc/modules.conf and the problem seems
to have gone away.

alias char-major-180 usbcore
alias char-major-188 usbserial

Maybe the bug is in the install scripts?
Comment 11 Kit Gerrits 2004-05-13 04:21:37 EDT
I have the same problem on my RHEL 3 server (Dell PowerEDGE 2400)

I don't run ALSA, but i do run CUPS.
It runs 3 printers, all of which have their own JetDirect port.
(no USB, serial or parallel)

May 12 15:56:46 RedHat01 modprobe: modprobe: Can't locate module char-
major-180
May 12 15:57:32 RedHat01 modprobe: modprobe: Can't locate module char-
major-180
May 12 15:59:40 RedHat01 modprobe: modprobe: Can't locate module char-
major-180
May 12 16:10:47 RedHat01 modprobe: modprobe: Can't locate module char-
major-180

I have also seen it crop up in other peoples' logs after xfs

Seeing as i have no reference point ot point the alias to, i will 
leave the modules.conf as is:

alias eth0 3c59x
alias eth1 e100
alias scsi_hostadapter aic7xxx
alias scsi_hostadapter1 aacraid
Comment 12 Kit Gerrits 2004-05-13 04:27:54 EDT
Oh, by the way, 
http://www.linuxquestions.org/questions/history/161070
...has the modules listed in his SuSE modules.conf

The warning itself seems to crop up when using the Print Manager from 
the System Settings to _edit_ printer settings.

Merely printing a test page does not cause the error.

Comment 13 Gary Lerhaupt 2004-05-24 15:12:33 EDT
What was the resolution this issue?  While it may be minor, it does 
seem like a bug to me.  These modprobe messages should not be printed.
Comment 14 Bill Nottingham 2004-05-24 16:26:03 EDT
Will go away in FC3/RHEL4.
Comment 15 Gary Lerhaupt 2004-05-24 16:31:53 EDT
Cool.  What was the fix?
Comment 16 Bill Nottingham 2004-05-24 17:52:13 EDT
alias char-major-188-* usbserial in /etc/modprobe.conf.dist.

Salt to taste for other releases.
Comment 17 Gary Lerhaupt 2004-05-25 10:25:08 EDT
Just to pester you some more, is there reason this cant be included 
in RHEL3 Update 3?
Comment 18 Gary Lerhaupt 2004-07-21 18:04:42 EDT
Rather than fixing the symptom, why not fix the cause?  These are 
coming from cupsd startup.  I'm looking further to understand why 
(though I assume its trying to scan for USB printers), but it still 
exists in cupsd latest (1.21).
Comment 19 Bill Nottingham 2004-07-22 14:32:01 EDT
It's just opening /dev/ttyUSBX to look for local printers, AFAIR.
Comment 20 Gary Lerhaupt 2004-07-22 14:43:17 EDT
Indeed.  Would it not be advantageous to have it first modprobe 
usbserial before attempting this?
Comment 21 Bill Nottingham 2004-07-22 15:04:48 EDT
It should really be done in the module configuration, though.
Comment 22 Gary Lerhaupt 2004-07-22 15:14:33 EDT
Okay, but isn't this somewhat of a deficient user experience?  
Mindful that I'm just playing devil's advocate here because I know 
these errors are harmless, but should not the program that is 
accessing major and minor numbers be responsible on the backend for 
setting up the OS to understand how to get to said major/minor 
numbers?  

Why not have the RH cups RPM add "alias char-major-188 usbserial" 
to /etc/modules.conf?  And now I see we've come full circle and you 
will be setting up modprobe.conf.dist to avoid this in RHEL4.
Comment 23 Gary Lerhaupt 2004-07-22 15:34:01 EDT
I checked modutils-2.4.26-16 in Alpha3 and it does not seem to 
include reference to usbserial.  If I can confirm this addition, we 
can close this out.
Comment 24 Bill Nottingham 2004-07-22 15:54:53 EDT
No, it's not in U3.
Comment 25 Gary Lerhaupt 2004-07-28 12:53:58 EDT
Courtesy of Matt Domsch.  This patch applied to modutils does in fact 
address the issue and causes usbserial to get loaded on cups 
startup.  Please apply for RHEL3 U4.:

--- modutils-2.4.25/util/alias.h.orig	Wed Jul 28 10:25:14 2004
+++ modutils-2.4.25/util/alias.h	Wed Jul 28 10:27:13 2004
@@ -155,6 +155,7 @@ char *aliaslist[] =
 	"char-major-109 lvm-mod",
 	"char-major-161 ircomm-tty",
 	"char-major-171 raw1394",
+	"char-major-188 usbserial",
 	"char-major-195 NVdriver",
 	"char-major-200 vxspec",
 	"char-major-206 osst",  /* OnStream SCSI tape */
Comment 26 Bill Nottingham 2004-09-30 16:16:30 EDT
*** Bug 128172 has been marked as a duplicate of this bug. ***
Comment 28 Matt Domsch 2004-11-10 16:47:11 EST
Confirmed RHEL3 U4 Beta1 package modutils-2.4.25-14.EL.src.rpm
includes this fix, thanks.  Closing.
Comment 29 John Flanagan 2004-12-21 09:37:00 EST
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-512.html
Comment 30 Mike Yates 2005-01-31 07:22:14 EST
I've had this error on a RH9 server with no USB devices.
It caused total hdd loss, so presumably "char-major-188" is a SCSI or
IDE module in this case?
I could find no reference to it anywhere in /etc
Comment 31 Nick 2005-01-31 11:38:17 EST
I have this same error on a RH9 server with no USB or Printers as 
well, it seems to be benign, although concerning because I cannot 
find the cause.  What else could it be?
Comment 32 Bill Nottingham 2005-01-31 15:11:50 EST
The error has nothing to do with 'hdd loss'; it's simply cups opening
/dev/ttyUSBX to look for printers. Adding:

alias char-major-188 usbserial

to /etc/modules.conf (for 2.4-based releases) should make the message
go away.

Note You need to log in before you can comment on or make changes to this bug.