Bug 854037 - Package Review: perl-XML-TokeParser
Package Review: perl-XML-TokeParser
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Package Review (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jitka Plesnikova
:
Depends On:
Blocks: 188273 850413 854554 854559
  Show dependency treegraph
 
Reported: 2012-09-03 12:28 EDT by Marcela Mašláňová
Modified: 2012-09-05 06:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-XML-TokeParser-0.05-12.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 08:06:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2012-09-03 12:28:30 EDT
SRPM: http://download.devel.redhat.com/brewroot/work/tasks/5638/4825638/perl-XML-TokeParser-0.05-2.1.el5.src.rpm
and build: https://brewweb.devel.redhat.com/taskinfo?taskID=4825638

I run build on srpm from RHEL-6. We should have at least the same version, not bigger than it's in RHEL-6.
Comment 1 Marcela Mašláňová 2012-09-04 04:43:41 EDT
I used new specfile from Fedora.
SRPM: http://download.devel.redhat.com/brewroot/work/tasks/9631/4829631/perl-XML-TokeParser-0.05-12.el5.src.rpm
build: http://brewweb.devel.redhat.com/brew/taskinfo?taskID=4829630

XML::Catalog is not used because I hope pcp could work without it.
Comment 2 Jitka Plesnikova 2012-09-04 06:26:32 EDT
rpmlint is OK.
Buildrequires are OK

Provides and requires are ok.

$ rpm -qp --requires perl-XML-TokeParser-0.05-12.el5.noarch.rpm 
perl(:MODULE_COMPAT_5.8.8)  
perl(Carp)  
perl(IO::File)  
perl(XML::Parser)  
perl(XML::Parser) >= 2
perl(strict)  
perl(vars)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1

$ rpm -qp --provides perl-XML-TokeParser-0.05-12.el5.noarch.rpm 
perl(XML::TokeParser) = 0.05
perl(XML::TokeParser::Token)  
perl-XML-TokeParser = 0.05-12.el5

License (GPL+ or Artistic) is ok.

Package is APPROVED.

Note You need to log in before you can comment on or make changes to this bug.