Bug 854064 - atril does not update
atril does not update
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: atanks (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 17:14 EDT by pkoz
Modified: 2014-02-02 17:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
[root@nbhu peter]# uname -a Linux nbhu 3.5.2-3.fc17.x86_64 #1 SMP Tue Aug 21 19:06:52 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux Desktop is Mate.
Last Closed: 2012-09-04 12:19:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pkoz 2012-09-03 17:14:17 EDT
Description of problem:
yum is unable to update atril:
...
Running Transaction Check
ERROR with transaction check vs depsolve:
libpoppler.so.18()(64bit) is needed by atril-libs-1.4.0-0101.fc16.x86_64
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
...

Version-Release number of selected component (if applicable):
 atril        x86_64   1.4.0-0101.fc16      mate-desktop-fedora-updates   618 k
 atril-caja   x86_64   1.4.0-0101.fc16      mate-desktop-fedora-updates    10 k
 atril-djvu   x86_64   1.4.0-0101.fc16      mate-desktop-fedora-updates    16 k
 atril-dvi    x86_64   1.4.0-0101.fc16      mate-desktop-fedora-updates    63 k
 atril-libs   x86_64   1.4.0-0101.fc16      mate-desktop-fedora-updates   987 k

How reproducible:
# yum update atril

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Update fails.

Expected results:
Packages are updated normally.

Additional info:
I upgraded recently from F16 to F17, with preupgrade. After that atril wouldn't work because it didn't find libpoppler.so.18, but when I made a symlink with that name to libpoppler.so.19 in /usr/lib64 it started to work all right.

My current version is
Name        : atril
Arch        : x86_64
Version     : 1.4.0
Release     : 0100.fc16

which can't be updated to
Name        : atril
Arch        : x86_64
Version     : 1.4.0
Release     : 0101.fc16
Comment 1 Bill Nottingham 2012-09-04 12:19:49 EDT
Please report this to where you got Atril from; Fedora can't fix those packages.
Comment 2 pkoz 2012-09-05 11:44:48 EDT
Yes, thanks, you were right, it was my mistake: after upgrading to F17 I forgot to switch to the mate fc17 repo, therefore I was trying to update mate components from the mate fc16 repo. Now, after I switched over, all seems to be all right again.

Note You need to log in before you can comment on or make changes to this bug.