Bug 854069 - Computer freezes during Bootup when Wireless NIC is hardware-disabled
Computer freezes during Bootup when Wireless NIC is hardware-disabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Greene
Fedora Extras Quality Assurance
:
: 872968 877545 883476 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 18:07 EDT by Aram Agajanian
Modified: 2013-01-25 06:05 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-24 17:38:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aram Agajanian 2012-09-03 18:07:40 EDT
Description of problem:
I installed the latest F17 updates on September 1, 2012.  After that, my notebook PC would freeze on boot of a 3.5 kernel.  It would seemingly freeze right before the login screen should appear.

The 3.4.4-5 kernel was still booting OK.

I have found that by disabling NetworkManager and enabling the network service the computer boots OK with the latest kernel 3.5.3-1.

I noticed that there wasn't any update to NetworkManager recently.  However, I tried downgrading bluez but that didn't seem to fix the problem.

Version-Release number of selected component (if applicable):
kernel-3.5.3-1.fc17.x86_64
NetworkManager-0.9.4.0-9.git20120521.fc17.x86_64

How reproducible:
happens every time

Steps to Reproduce:
1.  Boot F17 on my laptop with NetworkManager enabled
  
Actual results:
Boot freezes

Expected results:
Boot should finish and user should be presented with login screen

Additional notes:
http://www.smolts.org/client/show/pub_f9f12ecc-1786-4b87-9f4c-7c680262a869
Comment 1 Aram Agajanian 2012-09-11 23:33:17 EDT
My laptop will toggle a hardware enablement/disablement of the Wireless NIC when the Fn-F2 key combination is pressed.

It turns out that starting the NetworkManager service will freeze my laptop if the Wireless NIC is hardware disabled.

The NetworkManager service starts up normally if the Wireless NIC is hardware enabled.
Comment 2 Aram Agajanian 2012-09-12 21:25:32 EDT
I have noticed that when I installed updates on September 1, I hadn't booted a new kernel since August 9 (kernel-3.4.4-5).  So, this problem seems likely to be in kernel version 3.5.
Comment 3 Stanislaw Gruszka 2012-10-05 07:57:22 EDT
This is on BCM4313 wlan adapter.

Aram, please install kernel-debug and try to reproduce the problem, does debug kernel print information showing reason of the freeze?
Comment 4 Aram Agajanian 2012-11-24 20:51:39 EST
Sorry about the delayed response.

I have tested booting this computer with kernel-debug-3.6.7-4.fc17.x86_64.  I don't see any new information displayed at the time of the freeze.
Comment 5 Aram Agajanian 2012-11-24 21:49:04 EST
I have noticed a change in behavior with current updates.  Now, the startup of NetworkManager does not seem to cause the computer to freeze.  In particular, starting NetworkManager after boot with the wireless NIC hardware-disabled doesn't cause the computer to freeze.

The computer now freezes on boot whether the NetworkManager service is enabled or disabled.

Fortunately, I can hardware-enable the wireless NIC during the boot process by pressing the Fn-F2 key combination.  As long as it is enabled at the end of end of the boot process (when the mouse pointer first appears), the computer will boot.
Comment 6 Aram Agajanian 2012-12-04 21:37:21 EST
I did some additional testing of this freeze today (with the latest updates) and found the following:

- If I boot to runlevel 1 with the wireless NIC hardware disabled, the computer doesn't freeze.

- If I boot to runlevel 1 with the wireless NIC hardware disabled and then start the NetworkManager service, the computer will freeze.

- If I do the following:
    = boot runlevel 5 with the wireless NIC hardware enabled
    = hardware disable the wireless NIC by pressing Fn-F2
    = restart the NetworkManager service
  then the computer will not freeze.
Comment 7 Aram Agajanian 2012-12-05 23:55:24 EST
There is a possible fix for this in Linux 3.7.

https://lkml.org/lkml/2012/11/18/128
Comment 8 Josh Boyer 2013-01-07 16:48:53 EST
*** Bug 872968 has been marked as a duplicate of this bug. ***
Comment 9 Josh Boyer 2013-01-07 16:53:05 EST
Seems the patch queued for 3.7 was never submitted to stable.  F17 will be moving to 3.7 within the next 2 weeks or so.  I'll see how difficult a backport would be in the meantime.
Comment 10 Josh Boyer 2013-01-08 15:37:21 EST
*** Bug 877545 has been marked as a duplicate of this bug. ***
Comment 11 Josh Boyer 2013-01-09 09:36:48 EST
*** Bug 883476 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2013-01-22 09:27:49 EST
kernel-3.7.3-101.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2013-1025/kernel-3.7.3-101.fc17
Comment 13 Aram Agajanian 2013-01-22 22:21:11 EST
I installed F18 on my laptop over the weekend.  The kernel currently installed is 3.7.2-201.fc18.  There is no problem booting with the wireless NIC hardware-disabled.
Comment 15 Fedora Update System 2013-01-24 17:38:32 EST
kernel-3.7.3-101.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Nick Lamb 2013-01-25 06:05:17 EST
Upgrading to the 3.7 series kernel from F17 fixes my equivalent bug (877545 marked duplicate above) here, very satisfying to see this working at least before I have to hand the laptop back. Thanks to Aram for figuring out what the exact problem was and spotting the relevant patch going into Linux.

Note You need to log in before you can comment on or make changes to this bug.