Bug 854089 - SELinux is preventing /usr/bin/gpg from 'write' accesses on the file /home/JSAustin/.gnupg/random_seed.
SELinux is preventing /usr/bin/gpg from 'write' accesses on the file /home/JS...
Status: CLOSED DUPLICATE of bug 854088
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d6f217ca01b1dfddae1e27ebd4a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 22:04 EDT by Jeffrey S Austin
Modified: 2012-09-04 04:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 04:42:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-03 22:04 EDT, Jeffrey S Austin
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-03 22:04 EDT, Jeffrey S Austin
no flags Details

  None (edit)
Description Jeffrey S Austin 2012-09-03 22:04:08 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.5.3-1.fc17.x86_64.debug

description:
:SELinux is preventing /usr/bin/gpg from 'write' accesses on the file /home/JSAustin/.gnupg/random_seed.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/home/JSAustin/.gnupg/random_seed default label should be gpg_secret_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /home/JSAustin/.gnupg/random_seed
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that gpg should be allowed write access on the random_seed file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gpg /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                /home/JSAustin/.gnupg/random_seed [ file ]
:Source                        gpg
:Source Path                   /usr/bin/gpg
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           gnupg-1.4.12-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-146.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.3-1.fc17.x86_64.debug #1 SMP
:                              Wed Aug 29 18:23:34 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-09-03 22:00:32 EDT
:Last Seen                     2012-09-03 22:00:32 EDT
:Local ID                      2519521f-e061-42a2-b828-13a46eb0a79a
:
:Raw Audit Messages
:type=AVC msg=audit(1346724032.371:149): avc:  denied  { write } for  pid=4328 comm="gpg" name="random_seed" dev="dm-3" ino=10093549 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1346724032.371:149): arch=x86_64 syscall=open success=no exit=EACCES a0=7f4eb81490c0 a1=41 a2=180 a3=c0d92ba3 items=0 ppid=4279 pid=4328 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=gpg exe=/usr/bin/gpg subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gpg,mozilla_plugin_t,user_home_t,file,write
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t user_home_t:file write;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t user_home_t:file write;
:
Comment 1 Jeffrey S Austin 2012-09-03 22:04:10 EDT
Created attachment 609502 [details]
File: type
Comment 2 Jeffrey S Austin 2012-09-03 22:04:13 EDT
Created attachment 609503 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-09-04 04:42:33 EDT

*** This bug has been marked as a duplicate of bug 854088 ***

Note You need to log in before you can comment on or make changes to this bug.