Bug 854145 - The penality for strategy is not using the limited time frame for failure count
The penality for strategy is not using the limited time frame for failure count
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Imre Farkas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 03:46 EDT by Rehana
Modified: 2012-12-04 10:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The "Penalty for Failure" selection strategy did not limit the time frame for failures. This caused Cloud Engine to avoid preferred providers outside of their aggregate penalty time frame. This fix limits the time frame for aggregate penalties and provides successful launch to preferred providers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:18:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2012-09-04 03:46:40 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Login to conductor
2.configure mock and rhevm providers , with priority 1 for rhevm
2.Build and pushed image to rhevm and mock providers
3.Set the penality for failure parameter as
   Percentage penalty for each failure =50
   Time period over which the failures are aggregated (in minutes) =60
   The number of failures before the Provider Account should not be used=1
4.Launched instances on rhevm till i get failure "  500 : Cannot run VM. There are no available running Hosts with sufficient memory in VM's Cluster" on rhevm
5.After the time period (60 mins) is passed 
6.Added stirct order strategy with strict order score 1 for rhevm and 2 for mock
7.Launched instances 
  
Actual results:
All the new vm requests at step7 went to mock instead of going to rhevm provider

Expected results:
All the request at step 7 should go to Rhevm since the score is low for rhem provider

Additional info:

rpm -qa | grep aeolus
aeolus-conductor-doc-0.13.0-0.20120903030010git55da509.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120902230031git902c81c.fc16.noarch
aeolus-conductor-0.13.0-0.20120903030010git55da509.fc16.noarch
aeolus-configure-2.8.0-0.20120902230026git7dfddaf.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120903030010git55da509.fc16.noarch
aeolus-all-0.13.0-0.20120903030010git55da509.fc16.noarch
rubygem-aeolus-cli-0.7.0-0.20120902230028gitd64d64f.fc16.noarch
Comment 1 Imre Farkas 2012-09-04 06:05:45 EDT
Pull request sent:
https://github.com/aeolusproject/conductor/pull/34
Comment 2 Imre Farkas 2012-09-05 12:31:32 EDT
Pushed to 1.1:
commit a1b276d31af52ede08c199880ea9df3fca2bc412
Author: Imre Farkas <ifarkas@redhat.com>
Date:   Tue Sep 4 12:02:20 2012 +0200

    BZ #854145: limit the time frame for the penalty for failure strategy
    
    https://bugzilla.redhat.com/show_bug.cgi?id=854145
    (cherry picked from commit ae07680fc083af40d5f0b86396d243192b97cc69)
Comment 3 Steve Linabery 2012-09-07 18:02:37 EDT
in build aeolus-conductor-0.13.3-1.el6cf
Comment 5 Rehana 2012-09-21 11:02:42 EDT
Verified on 

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
Comment 7 errata-xmlrpc 2012-12-04 10:18:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.