Bug 854179 - Jenkins build failed after create an application using the same name with the application already deleted.
Jenkins build failed after create an application using the same name with the...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 05:10 EDT by Mengjiao Gao
Modified: 2015-05-14 18:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: devenv_2157
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:28:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mengjiao Gao 2012-09-04 05:10:32 EDT
Description of problem:
Firstly, I created an app with name "cake", and enable jenkins to it. Then I delete this app, and create another app with the same name "cake". After enable jenkins to the new app , I got a build failture.
The log message shown as follows:
".....
Cloning the remote Git repository
Cloning repository origin
ERROR: Error cloning remote repo 'origin' : Could not clone ssh://a5a17affb84f4306914050b02f8efe43@cake-1111111111111111.rhcloud.com/~/git/cake.git/
ERROR: Cause: Error performing command: git clone --progress -o origin ssh://a5a17affb84f4306914050b02f8efe43@cake-1111111111111111.rhcloud.com/~/git
......"



Version-Release number of selected component (if applicable):
devenv_2109,production

How reproducible:

always
Steps to Reproduce:
1.Create app named "cake".
2.Enable jenkins to the app with jenkins server named "jenkins".
3.Delete the app.
4.Create a new app ,and enable jenkins to it in the jenkins server "jenkins"
5.Build the new app in jenkins server.
  
Actual results:
Build failed .

Expected results:
It should build successfully.

Additional info:
I have looked up the configure file of the app in jenkins server, and found that the uuid of app in the configure file have not changed after I deleted the older one and created the new one.
Comment 1 Mengjiao Gao 2012-09-04 05:12:08 EDT
I have tried to delete the slave app "cakebldr" and reload the app with "rhc app reload -a cake", but the issue still exists.
Comment 2 Yujie Zhang 2012-09-06 06:23:46 EDT
This issue also exists on fork_ami_opensource_console_77.
Comment 3 Xiaoli Tian 2012-09-07 23:10:27 EDT
Raise severity to medium to get some attention, think this need to be fixed..
Comment 4 John Poelstra 2012-09-11 13:02:34 EDT
dan and paul looking at today
Comment 5 Dan Mace 2012-09-11 17:21:54 EDT
Fixed, waiting on pull request to merge before closing issue:

https://github.com/openshift/crankcase/pull/473
Comment 6 Xiaoli Tian 2012-09-12 02:19:51 EDT
(In reply to comment #5)
> Fixed, waiting on pull request to merge before closing issue:
> 
> https://github.com/openshift/crankcase/pull/473

Above code is merged in devenv_2157, move it to ON_QA.
Comment 7 Mengjiao Gao 2012-09-12 06:44:27 EDT
Tested this issue on devenv_2158, it have been verified since the deleted case will not exist in the Jenkins server. SO i will put it verified.
Comment 8 Mengjiao Gao 2012-09-12 06:54:48 EDT
(In reply to comment #7)
> Tested this issue on devenv_2158, it have been verified since the deleted
> case will not exist in the Jenkins server. SO i will put it verified.

Sorry to make a mistake in the comments, I mean that the jenkins job on jenkin server will be deleted when user deleted the related application on devenv_2158. 
So user can build jenkins successful using the same name with the application already deleted.
Comment 9 Dan Mace 2012-09-12 09:44:55 EDT
I didn't update the status because the pull request was still outstanding when I left for the day, but it seems like QE already tracked it down and tested it.

Many thanks for the rapid turnaround!

Note You need to log in before you can comment on or make changes to this bug.