Bug 854202 - Upgrade-Temp admins not removed after upgrade
Upgrade-Temp admins not removed after upgrade
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Steve Linabery
Giulio Fidente
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 06:51 EDT by Rehana
Modified: 2012-12-12 10:17 EST (History)
4 users (show)

See Also:
Fixed In Version: aeolus-configure-2.8.8-1.el6cf
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-12 10:17:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2012-09-04 06:51:22 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install aeolus on F16
2.aeolus-configure -p mock
3.Added aeolus1_1.repo
4.yum update
5./usr/share/aeolus-conductor/script/aeolus-upgrade  -a
6..rpm -qa | grep aeolus
aeolus-conductor-0.13.0-0.20120904080008git280b413.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120904040029git902c81c.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120904080008git280b413.fc16.noarch
aeolus-configure-2.8.0-0.20120904040024git7dfddaf.fc16.noarch
aeolus-all-0.13.0-0.20120904080008git280b413.fc16.noarch
rubygem-aeolus-cli-0.7.0-0.20120904040025gitd64d64f.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120904080008git280b413.fc16.noarch
7.aeolus-restart-services
  
Actual results:
   
 As soon as i logged in after the upgrade, observed that the "Temp_admin" was listed in the user list,but After executing aeolus-configure rhevm, vshere the temp admin user got removed


Expected results:
Temp admin should not exists

Additional info:
Comment 2 Steve Linabery 2012-09-11 11:28:50 EDT
I can't reproduce this. I did the following 5 times and only see one administrator account using rails console afterwards:

aeolus-cleanup; aeolus-cleanup; yum -y remove aeolus-* rubygem-aeolus-*
yum -y install aeolus-all aeolus-conductor-devel && \
 aeolus-configure -p mock && \
 yum --enablerepo=aeolus-nightly -y update &&
 /usr/share/aeolus-conductor/script/aeolus-upgrade -a -y && \
 aeolus-restart-services
Comment 3 Giulio Fidente 2012-10-02 09:58:46 EDT
I tried to reproduce this on fedora17 (as fedora18 is now already in alpha state)

The builds I get installed on fedora17 are the following:

aeolus-conductor-0.10.4-1.fc17.noarch
rubygem-aeolus-cli-0.5.0-1.fc17.noarch
aeolus-conductor-daemons-0.10.4-1.fc17.noarch
aeolus-all-0.10.4-1.fc17.noarch
rubygem-aeolus-image-0.5.0-1.fc17.noarch
aeolus-conductor-doc-0.10.4-1.fc17.noarch
aeolus-configure-2.6.1-1.fc17.noarch

Which repo should I use to upgrade these packages and try to reproduce the bug?
Comment 4 Rehana 2012-10-03 01:14:22 EDT
please use "aeolus1_1.repo" of upstream aeolus to upgrade.
Comment 5 Giulio Fidente 2012-10-03 09:13:02 EDT
as per Dave's suggestion, this is not happening on RHEL using aeolus-configure-2.8.8-1.el6cf so I'm moving the bug to VERIFIED state.

if the problem is still happening on Fedora, it should be reported against the Fedora component aeolus-configure, not the Cloud Engine product from Red Hat
Comment 6 James Laska 2012-12-12 10:17:53 EST
CloudForms-1.1 shipped with aeolus-conductor-0.13.24-1.el6cf, aeolus-configure- 2.8.11-1.el6cf, imagefactory-1.0.2-1.el6cf, iwhd-1.5-2.el6, and oz-0.8.0-6.el6cf

Marking this bug CLOSED CURRENTRELEASE.  Please reopen if the problem has not   been addressed in the 1.1 product.

If the problem remains, please file packaging bugs using Fedora + conductor against Fedora.

Note You need to log in before you can comment on or make changes to this bug.