Bug 854230 - tdb-tools package conflict with Samba 3.6.7
tdb-tools package conflict with Samba 3.6.7
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: unclassified (Show other bugs)
2.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Jose A. Rivera
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-04 08:59 EDT by Ujjwala
Modified: 2013-09-23 18:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ujjwala 2012-09-04 08:59:42 EDT
Description of problem:
The tdb-tools package contains binaries and manpages that are also provided
by the samba package.
When I try to install Samba 3.6.7 on RHS 2.0.z update 2 , files conflict with tdb-tools-1.2.1-3.el6.x86_64 package.

Version-Release number of selected component (if applicable):
tdb-tools-1.2.1-3.el6.x86_64
libtdb-1.2.1-3.el6.x86_64

Tested it on RHEL 6.2 and 6.3 

How reproducible:
Always

Steps to Reproduce:
1. Try installing Samba 3.6.7 where tdb-tools is already installed 
2. Or Install Samba 3.6.7 and then try installing tdb-tools

  
Actual results:
Transaction Check Error:
  file /usr/bin/tdbbackup from install of tdb-tools-1.2.1-3.el6.x86_64 conflicts with file from package samba3-3.6.7-44.el6.x86_64
  file /usr/bin/tdbdump from install of tdb-tools-1.2.1-3.el6.x86_64 conflicts with file from package samba3-3.6.7-44.el6.x86_64
  file /usr/bin/tdbtool from install of tdb-tools-1.2.1-3.el6.x86_64 conflicts with file from package samba3-3.6.7-44.el6.x86_64
  file /usr/share/man/man8/tdbbackup.8.gz from install of tdb-tools-1.2.1-3.el6.x86_64 conflicts with file from package samba3-3.6.7-44.el6.x86_64
  file /usr/share/man/man8/tdbdump.8.gz from install of tdb-tools-1.2.1-3.el6.x86_64 conflicts with file from package samba3-3.6.7-44.el6.x86_64
  file /usr/share/man/man8/tdbtool.8.gz from install of tdb-tools-1.2.1-3.el6.x86_64 conflicts with file from package samba3-3.6.7-44.el6.x86_64



Expected results:
samba should not conflict with tdb-tools

Additional info:
Comment 2 Christopher R. Hertel 2012-10-30 02:06:52 EDT
I believe that Jose and Ujwalla have discussed this problem in an offline thread.

Jose:  Please update with any comments or conclusions.
Comment 3 Christopher R. Hertel 2012-11-12 18:39:16 EST
I am passing this ticket along to José for follow-up.
Comment 7 Scott Haines 2013-09-23 18:25:56 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.